Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Ubuntu 11.10 on my MacBook Pro, and I have enabled two-finger scroll.

Now I'm unable to move a window with the trackpad, which is usually done by click-and-holding the window title (with one finger) and dragging (with another finger).

How do I move a window without disabling the two-finger scroll?

share|improve this question

Now I don't use a multi-touch pad, but the way I do it is double-tap (one finger twice) on the title bar, but on the last tap stay down and drag it.

You might have to make sure "Enable mouse clicks with touchpad" is enabled in the touchpad Mouse Settings.

share|improve this answer
Thanks, you made me figure out what I could do: I can move the window if I just click-and-hold once on the title bar, and use that same finger to move the window. I have disabled tap-to-click, since the the whole MacBook trackpads works as a regular mouse button. I'd still want to move windows the way I do it in MacOSX, though... – neu242 Feb 18 '12 at 14:42
According to this you should be able to use the three-finger click-drag to move a window. Thought you may have to do it on the title bar. – Chuck R Feb 20 '12 at 6:37
Yeah, I've discovered that. Very annoying, since I want three-finger swipes to do something else: :-P – neu242 Feb 20 '12 at 11:05

I'm not familiar with MacBook peculiarity, but as far as I know you can always press Alt key and drag the window from any point contained in it (not just title bar).

share|improve this answer

Read the Ubuntu wiki on Multitouch. In 11.10 and 12.04, a three-finger swipe on a touchpad moves the window and it seems impossible to disable as neu242 comments.

In 12.04 a three-finger tap brings up red circles that (for me) start moving the window around at random. I think this is the "Unity MultiTouch Grab Handles". You can turn this off if you install CompizConfig Settings Manager.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.