Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to flashplugin, I cannot watch videos on the internet. I also cannot watch some other youtube videos.

I'd say it's a bug in Gnash, any ideas?

share|improve this question
    
you can report bugs for Gnash in this link gnu.org/software/gnash/bugs.html and about your problem I don't understand are you bugs did from use Gnash only or not you try to use flash player from adobe it's working fine –  Mahmoud20070 Feb 18 '12 at 12:30
    
Possible duplicate: askubuntu.com/q/105101/18612 –  WarriorIng64 Feb 19 '12 at 1:35

2 Answers 2

Esta es la solución cuando el problema es que antes de la actualización si que se veían los vídeos, ya que estaba correctamente instalado el plugin Flash Player, pero han dejado de verse tras la actualización.

Ejecutar en la terminal: gksu gedit /usr/bin/firefox con lo que se abre el ejecutable de Firefox con el procesador de textos, con permisos para modificarlo. Debajo de la primera linea del archivo,donde dice: #!/bin/sh hay que añadir la línea: export XLIB_SKIP_ARGB_VISUALS=1 de forma que ésta sea la segunda línea del archivo. Guardar los cambios en el archivo, cerrarlo, y reiniciar Firefox, y ya se vuelven a ver los vídeos.

Al actualizar Firefox se reescribe la configuración del navegador pero no las opciones de vídeo como por ejemplo las transparencias, lo que hace que el plugin falle al renderizar la imagen. Lo que se hace añadiendo esta línea es decirle que tenga en cuenta dichas transparencias.


English translation (with the help of Google Translator, plus formatting and clarity changes):

Here's the solution, when the problem is that the videos worked before the upgrade, but not after.

Run in terminal:

gksu gedit /usr/bin/firefox

That opens the Firefox executable script with a word processor, with permission to modify it. Below the first line of the file where it says #!/bin/sh, you must add the line:

export XLIB_SKIP_ARGB_VISUALS=1

That should be the second line of the file. Save the changes to the file, close it and restart Firefox, and you should be able to re-watch the videos.

Firefox was rewritten to update the browser settings but no video options such as transparency, which makes the plugin fails to render the image. That line, once added, accounts for those transparencies.

share|improve this answer

Install the Flash Aid add-on on firefox and follow the wizard instructions.Restart the browser and the problem should probably be fixed. At least that was the solution for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.