Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I believe the problem may be related to this question.

I logged twice to guest account. The first time I've chosen unity and something went wrong. The other time I used gnome shell, it worked for a while, and then I switched to my regular user. I haven't rebooted since. After a few hours I noticed that there are two compiz processes runing using 100% CPU, so I tried to kill them.

htop output screenshot

Thanks to people on the ubuntu's IRC chat I tried:

sudo killall compiz
sudo killall -9 compiz
sudo pkill -9 compiz
sudo kill -9 15384

None of this commands killed the process (but all of them return 0).

I've also tried restarting X server with /etc/init.d/lightdm restart.

This answer talks about how it may not be possible to kill a process in uninterruptible sleep. I believe that's not the case -- The S column is representing state and the R symbol means "Running".

This answer tells me that there are some system processes impossible to kill, and their names are in brackets. That's not the case:

ps ax output screenshot.

bc81 on IRC linked me this answer, and suggested that it may not be possible to kill unity when the Launcher or Unity processes are running. They don't seem to be running though (checked with sudo ps ax | grep -i launcher).

share|improve this question

closed as too localized by Jorge Castro, Eliah Kagan, Bruno Pereira Jan 10 '13 at 14:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Do you tried to use --replace ? e.g compiz --replace --display :0 from tty1, maybe that kills them. –  Eduard Gotwig Feb 18 '12 at 13:01
    
Some people on the IRC suggested that, but I don't know how to do it. I'm currently not logged in as any of the guests running compiz, and with SU replace complains that it can't find display. –  Barnaba Feb 18 '12 at 15:45
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. This is to help with the Ask Ubuntu Clean Up. If you feel this question is not abandoned, please flag the question explaining that. :) –  Seth Jan 9 '13 at 3:19

Browse other questions tagged or ask your own question.