Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Gnome crashes constantly when I open web pages containing flash so I tried to turn off the hardware acceleration. I opened the Adobe flash player settings panel but found that the buttons are not clickable.

I can still switch between display/privacy/storage... panels using Tab and Enter key. But for others like the "Enable hardware acceleration" checkbox this won't work.

Anyone knows how to solve it?

share|improve this question
    
I would reccomend to reinstall flash. What browser do You use, what flash? How did You install it? –  Misery Feb 18 '12 at 8:12
2  
The problem appears in both Chromium and Firefox. I installed adobe flash player from Ubuntu software center. Reinstalling doesn't work. –  Zeyu Feb 20 '12 at 5:33
    
Please deliver us the version of Ubuntu You are using. Maybe you should try to install flash not from USC but by downloading it from websiite (there is a special version for Ubuntu) –  Misery Feb 20 '12 at 8:00
add comment

7 Answers 7

The easiest way to disable hardware acceleration in flash is to do it in the flash player window from the right click > settings & un-check the box for hardware acceleration.

In many cases though the box can't be clicked. If that's the case then you must not have scrollbars present so use F11 to fullscreen the window, then you'll be able to click in the box. After doing so press F11 again to return to normal window. (happens mainly when using compiz. On a 32 bit player going fullscreen works here, on a 64 bit player it currently doesn't

I don't see a "Adobe flash player settings panel" but if it's available with the option to disable hw accelerating then try to full screen it if the box isn't clickable

An alternate method would be to access the player settings in a non compiz session which is the surest way to do

share|improve this answer
1  
Going full screen worked for me, thanks. –  Yuriy Voziy May 3 '12 at 7:19
add comment

I was able to make it work. Ahuh!

Use Tab button until it highlights the whole Flash Player settings box, then press Tab button again until it highlights the "question mark" button on the right upper part of the box. Press Space bar or Enter button repeatedly until it opens another tab on your browser. Now go back from the previous page where the Flash Player settings is, press Tab button again until it highlights the "Allow button" or "Deny button" depending on what will you do. Press Space bar or Enter button and voila! There you go!

Hope it helps. Have a pleasant evening everyone! :)

share|improve this answer
add comment

You can change flash privacy settings for specific websites online.

The settings are stored in your browser and then you can do things like use Youtube and your own webcam to create and upload a video.

share|improve this answer
add comment

Have you tried gnash? It's available via software centre, you could try uninstalling the adobe flash and using gnash instead...

share|improve this answer
add comment

I had the same problem and logging under Unity 2D allowed me to click and change the Flash settings. Logging again under Unity 3D revealed that the settings were conserved between the two sessions.

share|improve this answer
add comment

You have to download the .deb from Adobe Flash web. Later you have execute it in Ubuntu Software Center and enable Adobe Flash KDE. When you enable adobe flash KDE you can change the privacy and web exception in Flash Control Panel.

System → Preferences → Adobe Flash

share|improve this answer
add comment

Recently I updated to Flash Player 11.2.202.233 and ran into a problem where I did not have audio and video. Removed 11.2.202.233 and installed Flash Player 11.1.102.63. No more problems!!! Please refer to these instructions on Mozilla Support and Adobe's Archived Flash Player versions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.