Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can I install glib >= 2.30 on Ubuntu 11.04?

I mean this package from above link

share|improve this question

closed as too localized by Luis Alvarado Apr 9 '13 at 16:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer

It wont work :(
As no one commented I thought to go in this adventure. I had 2 packages wanting this glib version, and I'll mention popular one - Gimp 2.7.4

I managed to find deb packages in Debian testing, and managed to replace glib 2.28 by making local temporary repository

After this I launch gimp ./configure, and now it needs newer version of gtk+, then it needs newer version of pango, which needs even newer version of glib - 2.32, and I already messed enough with 2.30. I rebooted

...that's not all. Now I can't login, it simply displays logon screen and stays forever. I go to netroot recovery console, but have no Internet. I boot in Windows and download glib 2.28, then I installed this with aptitude and reboot when famous error pops - no permissions for .ICEauthority, so I can't login still. Booting in Windows and searching showed me that this error is everywhere with all kind of solutions, some of which I tried without success, like deleting file, changing various permissions and similar, until I installed gnome-session package, which was mentioned as last comment on askfedora I think.

That's it. Now back on track and thought to share this.

Cheers

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.