Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded my Mythbuntu box to 11.10.

LightDM worked for a while and then I configured autologin on my user account. After some time, I've removed some packages to lean down the system.

Now when I log out (from either Unity or Gnome Shell) I lose the X session, LightDM doesn't start back up.

If I disable autologin through /etc/lightdm/lightdm.conf I get no login screen & no X.

As I said, autologin works and gives me a Ubuntu Classic desktop.

This is the only reference in dmesg to lightdm;

[   17.351023] type=1400 audit(1329530135.420:19): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm-guest-session-wrapper" pid=1097 comm="apparmor_parser"

Can anyone help?

share|improve this question

1 Answer 1

Try to install unity-greeter.

I broke LightDM and this solved it, but I don't have the option to run Unity or Gnome Shell (they're installed).

Edit: I solved my problem installing 'gnome-session'.

share|improve this answer
    
Thanks, I think when I removed compiz the lightdm started having trouble, anyway, I re-installed everything to do with unity and gnome shell and all is good. –  Ben Feb 22 '12 at 10:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.