Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Ubuntu 11.10. My father has a dual boot of Windows7 and Ubuntu 11.10 but had activated a driver for his Nvidia integrated card when he installed Ubuntu.

The other day I installed a MSI Radeon PCI Express card in his computer but when I booted to Ubuntu all I got was a purple screen.

I had read some things about going in to recovery but when I click it it doesn't do anything. Is this a conflict with the driver of Nvidia? Can anyone tell me step by step with commands on what I need to do to get his new Radeon card working? i would like to say thank you very much so far for your help.I did get the proprietary driver removed from the integrated nvidia graphics card and a successful reboot back into ubuntu with nvidia open source driver.Then i shut down the computer and installed the radeon graphics card,when i booted up to ubuntu i recieved the same result of a purple blank screen.If i try recovery mode Iget nothing.I checked your link of is my ati card supported and it says it does support this card.My first question is should i run the sudo command in terminal that builds up before the drivers for ati before i install the ati card then reboot?i also noticed on the new ati card it says this" Note that RadeonHD 6xx0 chips will need kernel 2.6.38 for open-source mode-setting, xf86-video-ati/radeon 6.14.0 for 2D acceleration (EXA/Xv), and Mesa 7.11 for 3D acceleration."

share|improve this question

1 Answer 1

You need to first remove the drivers that were installed by the Additional Drivers tool prior to installing you new card. Do the following

  • Remove the ATI card from the computer and boot to Ubuntu, it should load without issues
  • Open the dash and look for the Additional Drivers tool

enter image description here

  • Select the Nvidia driver currently in use, it should have a green mark on it and once you select it the button on the right bottom corner will say remove, press remove and let Jokey do it's magic

enter image description here

  • Make sure that there is not xorg.conf file loading any pesky drivers. Open a terminal and type sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old. This will save any xorg.conf (if any, if you get a file not found fault here move on and ignore it) in to a xorg.conf.old file inside the same directory.

  • Reboot

If all when well your system is not using the default open source drivers. You are free to shutdown, install the ATI card and install the drivers for it.

You have 2 choices with the ATI card, open source drivers or the proprietary AMD drivers. For more information on how to install/remove/revert AMD drivers in Ubuntu 11.10 please visit this post

If you get stuck along the road please edit your question to add any steps you did till now and drop a comment so we can further help you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.