Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I had 11.04, there was an option "ask for password", something like this. I checked it out, and instead of password field I got "login" button. Now, when I got 11.10, I doesn't see that option. But I still don't have "password" field. Instead of typing password and hiting enter, I have to click on "Login" button, and when I see my wallpaper etc. window asking for "password to unlock keyring database" appear :/.

How can I change that? I want to type my password, now everybody can login into my account without knowing password. And how to get rid of that window?

My question is similar to this: My PC does not ask password in Login even if I set it to ASK on login but I can't see that option in 11.10 :/. Please, help, it's little bug, but it's annoying me :/.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Have you tried to create second user with admistrator role? Check if it happens the same for the new one, what happens when you just log off from one of the accounts and try to change your settings from the new user.

share|improve this answer
    
Okay, I created new user with root priviledges. I logged into that new user, and changed my password. Now I got password field instead of Login button :). But I still got window appearing after login, asking for password to "Unlock the keyring database", how can I get rid of that window? –  G G Feb 18 '12 at 10:25
    
*that window asked me for password to "Unlock your login keyring", I made mistake in previous post. –  G G Feb 18 '12 at 10:31
    
Okay, thanks for help. I get rid of that window, using this advice karuppuswamy.com/wordpress/2010/06/18/… Now everything is good :-). –  G G Feb 18 '12 at 11:14
    
Sorry for not getting back to you before. I'm glad you were able to fix everything ;) –  aderojas Feb 19 '12 at 3:46
add comment

Go to system-settings, then User-Accounts. There you can uncheck the automatically log in box.

share|improve this answer
    
ph1b: That's the problem. I got that unchecked, and I'm not logging automatically, but instead of password field I got "Login" button. I think you didn't understand my problem. Im not logging automatically, but still I can login without knowing my password. –  G G Feb 17 '12 at 21:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.