Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I updated my Ubuntu 11.10 to kernel version 3.0.0-16-generic.

After the update I restarted the computer and then I got stuck in a loop right after the initial screen where all the modules are loaded (showing an [OK] text on the right). All I see is the mouse pointer and then it goes back to that screen, and so on. In some cases, I can see an error that says: initctl: Event failed.

What should I do?

Thanks in advance, Jonathan

share|improve this question

closed as too localized by jokerdino, nitstorm, Takkat, Jorge Castro, fossfreedom Feb 20 '12 at 11:13

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Does booting from a ubuntu livecd work? –  balloons Feb 17 '12 at 22:21
    
hi, yes, it does. what can i do from the livecd to fix this? thanks! –  Jonathan Feb 17 '12 at 23:52
1  
The OP solved the problem by reinstalling. So, no answer can be verified whether it worked or not. Hence, I think this question should be closed as "too localized". –  jokerdino Feb 19 '12 at 4:01

3 Answers 3

Finally I tried a more radical approach: reinstalling ubuntu using a livecd... it took me two attemps, the first one killed my video card, and finally the second one solved all the problems! Thank you all for your help. Jonathan

share|improve this answer

As you mention you can boot from a live cd, you can reset the boot loader manually (which may be part of the problem.)

Boot to the live CD

Determine the block storage device (hard drive partition) of the old system's boot drive, i.e. /dev/sda3 or some such (this is the location of your /boot files in the old system.) By default, it's on the root partition, you can figure it out by doing in terminal:

sudo mkdir /recover
sudo mount /dev/sda2 /recover
ls /recover

This is assuming your root or boot drive is on /dev/sda2, it may be on /dev/sda1-?? or /dev/sdb? or /dev/sdc? ; it would really depend on your system. Assuming it's /dev/sda2...

Terminal:

sudo -s
mount /dev/sda2 /mnt
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
mount --bind /proc /mnt/proc
chroot /mnt

You're now chrooted into your existing system. Update the system to ensure that the upgrade worked.

apt-get update
apt-get full-upgrade

then to be sure the boot system is working, run

update-grub
grub-install /dev/sda

(this assumes your on a single boot system with the disk device /dev/sda with just ubuntu, using grub2 as your boot manager.)

share|improve this answer

Boot the older kernel. To do so, press and hold shift while booting. Then you'll get to the Grub menu. One of the options is something like "Previous versions". Then select the kernel you used before, and everything should be fine.

share|improve this answer
    
Hi, thanks for the answer. Actually I had already tried that but it didnt work either, i have several kernels in that list and none of them worked. –  Jonathan Feb 17 '12 at 19:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.