Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When i start google earth on ubuntu it shows a black screen. It used to work but one time it show a black screen. I tried installing it again and rebooting and everything but it didn't work. What is wrong?

share|improve this question

closed as too localized by Eliah Kagan, maythux, con-f-use, Ringtail, Mitch Oct 11 '12 at 14:26

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! – Jorge Castro Nov 27 '11 at 23:02

I fixed it by using a different dns such as , after somebody suggested it may be an ipv6 problem.

share|improve this answer

Is the whole screen a black screen or just the right window where the 3d view of the earth appears? How did you install google earth. Did you download the original package and install the libgl with "wget -O"? If you are using 10.04, you can install Google Earth from mediabuntu package, maybe this works. Otherwise, if you use 10.10, you can use this guide: This works for me in 10.10 after I got crashes and black screens while using the original package. Using the original package was a mistake, because the original package never worked for me.

share|improve this answer

I had the same problem on my 64bit Ubuntu 12.04 machine. I've tried clearing Google Earth's cache, purging Google Earth, and then reinstalling it. But that didn't fix the problem. So I went and tried something a bit more extreme. Maybe this is too extreme, but oh, well. I went and un installed all my 32 bit software, including Google Earth, and then reinstalled google-earth-stable. CAUTION: this may be drastic move, and may possibly mess up some things. Sorry if it does. You have been warned.

synaptic-kde -> Architecture -> arch :i386 -> sort by what's installed, and use click first item in range, followed by shift clicking last item -> right click -> Mark for removal -> then click Apply in the toolbar. Make note of what it uninstalls, and if there's anything you want back. CAUTION: this may remove alot, maybe too much, and you might miss something you need so look over it carefully.

You may want to reinstall some items that got removed such as doing a command like:sudo apt-get install zsnes skype playonlinux acroread and so forth...

To me this seams like a drastic way of fixing it, but at least it worked for me. (and seams to have fixed another minor unrelated problem) I'm betting there's a more precise way of fixing it. Your welcome to post which subset of this you think actually fixed the problem, and other cautions to those that may try to fix Google Earth this way, etc...

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.