Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I reliably disable snapping windows? When I drag a window around by its titlebar and near the upper edge, it tints and wants to maximize if I let go of the mouse then (trying to park my app there, not cover the whole workspace!)

Until Unity becomes more productive for my work style I switched to cairo-dock with effects for now (which also is not without issues).

As the logged in user I have run ccsm the Compiz manager and disabled Snapping Windows altogether, and verified many times. Doesn't seem to care. Haven't filed a bug rep yet as maybe there's some other setting I don't know about. Nothing else results in the CompizConfig search when I try snap or snapping. Any other ideas?

Ubuntu Desktop 11.10 32bit, hwinfo:

 28: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1002_7145
  Hardware Class: graphics card
  Model: "ATI Radeon Mobility X1400"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x7145 "Radeon Mobility X1400"
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x0094 
  Driver: "radeon"
  Driver Modules: "drm"
  Memory Range: 0xd0000000-0xd7ffffff (ro,non-prefetchable)
  I/O Ports: 0x2000-0x2fff (rw)
  Memory Range: 0xc8100000-0xc810ffff (rw,non-prefetchable)
  Memory Range: 0xc8120000-0xc813ffff (ro,non-prefetchable,disabled)
  IRQ: 46 (306 events)
  Module Alias: "pci:v00001002d00007145sv00001025sd00000094bc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is active
    Driver Activation Cmd: "modprobe radeon"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #13 (PCI bridge)
share|improve this question
    
Could it possibly get reactivated by some event eg. sliding to another workspace? Having trouble finding a cause that's consequential. Snapping just seems to come back at some point and I can't figure out why. –  Marcos Feb 17 '12 at 19:54
    
disabling "Place Windows" under ccsm's "Window Management" also made it stop snapping to top border. However that plugin seems to be more another victim than cause to whatever underlying problem, and needed to re-enable anyway it to avoid ill effects without it. –  Marcos Feb 20 '12 at 14:00

3 Answers 3

up vote 1 down vote accepted

My previous answer turned out to be wrong (not always off).

Finally found the answer! http://askubuntu.com/a/72480/38636

Seems it's also know as “drag to maximize” behaviour in Compiz and disabled in CCSM Grid plugin, Edges tab, Top Edge :: set to None.

share|improve this answer

Disabled "Scale" under ccsm's "Window Management" .... and snapping to maximize suddenly stopped, finally! A lot of other things changed too, namely many updates since last month.

It would go such a long way if this plugin like so much else had a nearby description of what it actually does and when...not just "Scale Windows" on ccsm's left column and nothing else mentioned.

share|improve this answer
1  
Excellent & well done. If possible, please consider closing some of your other open questions by selecting the best answer (if they have one). We need users to maintain their questions so that the site can be an effective tool for the next person with your problems. For more details on best practices consider reading the FAQ on asking questions. –  fossfreedom Mar 4 '12 at 21:39

Try enabling wobbly windows in ccsm. I know that you cannot have snapping windows working when wobbly is activated. This may work, for it is what i have selected in my own compiz

share|improve this answer
    
Thanks, I tried that suggestion. Their effects both seems to coexist without interference though, and selecting incurred new latency before getting ready to be moved, so I switched Wobbly back off. Maybe Snapping goes by another name in some other daemon/setting? –  Marcos Feb 17 '12 at 17:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.