Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to change the desktop font color in xubuntu after I replaced thunar with nautilus to be the default file manager. Right now I have gray text color which is not visible on almost any wallpaper. I set up the gtk theme using gnome-tweak-tool but it's not using it because in the css files and gtkrc file for gtk2 the text color is set to #ffffff

share|improve this question
add comment

2 Answers 2

The problem is that nautilus and xfce are not a good match because nautilus tries to take over the desktop - which results in a kind of gnome/nautilus desktop, other than the normal Xfce desktop. I could not find a way to keep and use Nautilus in Xfce so I had to give it up because I didn't need it - and now I don't have this problem anymore. If you want to keep Nautilus you have to deal with this problem. See one suggestion here and also you may find about a similar problem here. Nautilus lovers tend to blame xfce for this problem, I see it as an incompatibility and think that this is more a Nautilus issue - as a file explorer designed to be the default program in other environments than Xfce.

share|improve this answer
add comment

I got this working. Xubuntu 12.04, transition from Thunar to Nautilus, including default desktop management.

Once you've transitioned to Nautilus to manage your desktop, the text of desktop icons will be grey or some other unreadable colour. To change this:

  1. Go to settings manager -> Appearance.
  2. Under the style tab, which opens by default, see which theme you are using.
  3. In your terminal, type: gksu nautilus /usr/share/themes
  4. Browse to the folder of the theme you are using.
  5. I was using Greybird. In that theme's folder, I went to the gtk-3.0 folder, and pasted the code from the following post to the bottom of the gtk-widgets.css file (source: http://ubuntuforums.org):
  6. Close your text editor.
  7. Close your root nautilus folder
  8. Terminal (Ctrl+Alt+T): killall nautilus
  9. Alt+F2: nautilus

That should do it!

Side note: change the new nautilus desktop background with dconf editor, at the following location in the tree: org -> gnome -> desktop -> background

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.