Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Nautilus I tried to rename a .desktop file, but Unity (or is it Gnome? I suspect it's Unity but please correct me if I'm wrong) then renamed the file to end with .desktop.desktop - not what I wanted. After a bit of messing around I guessed that Unity was automatically adding a file extension and managed to rename it so it ended with only one .desktop

How can I turn off automatic file extension renaming? Or is this the only filetype which has this annoying behaviour? In which case I can live with it.  (But I'll be tutting a lot.   ;-)

I'm used to renaming files, so unexpected behaviour in both Nautilus and Thunar is annoying and gets in the way of my completing simple tasks. Thunar is even worse - it doesn't show the file extension at all!

share|improve this question

You are right, this is only with .desktop files. This was introduced a couple of releases ago to my knowledge, probably to make sure you don't break a starter/launcher.

share|improve this answer

Using the mv command via the command line does not have this issue, if you do need to rename the file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.