Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Dual boot with windows xp and Ubuntu 10.4 on my PC. I have installed Ubuntu 11.10 on the Ubuntu 10.4. After restart it is directly entering into Ubuntu 11.10. There is no menu at start up for selecting Operating system.

share|improve this question
    
I'm worried you may have accidentally installed Ubuntu in a way that wiped out your Windows system. If so, then at this point, it would probably be hard or impossible to recover any data from your Windows system. But you should check and see if this is what happened. To do so, run sudo parted -l. This will list all your partitions. If there is no Windows (NTFS) partition, then your Windows system is gone. Since the output of parted can sometimes be hard to interpret, I recommend editing your question to include all the output of sudo parted -l. –  Eliah Kagan Apr 23 '12 at 0:27
    
please provide the output of #sudo fdisk -l –  shantanu Aug 29 '12 at 5:05

1 Answer 1

Open up a terminal window. Then type:

gksu gedit /etc/default/grub

You'll have to type in your password. This will open up the grub configuration file. Look at the first several lines. You should see something like:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=1

GRUB_HIDDEN_TIMEOUT=0 will hide the menu, but as you can see, it is commented out in mine (by prepending with #), so I do see the menu on boot. If is it not commented out, do so.

Also, note that GRUB_TIMEOUT=1 sets the time until the grub menu automatically chooses the first option. I've set it to 1; setting it to 0 would effectively hide it also. So if it is 0, change it to a nonzero value.

Finally, after making the necessary change, save and exit the editor. At the terminal, as suggested in the grub config file, type

sudo update-grub 

to make the changes stick.

share|improve this answer
    
Thanks. The menu is being shown. But Windows XP is not listed in the menu. The windows partitions are present. In /boot/grub/grub.cfg doesn't contain windows XP menu entry. –  pavan Feb 17 '12 at 14:21
    
Ok. Here's a way to add the Windows partition to the grub menu: ubuntuincident.wordpress.com/2011/07/21/… Let me know if it works. –  Chan-Ho Suh Feb 17 '12 at 20:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.