Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Ubuntu. I use Skype and often the main window just disappears from my desktop. The Skype instance itself is still running in the background. I know this because I can see its notifications on the bottom right side of the screen.

If I click on the Skype icon again, Ubuntu will launch a new instance instead of maximizing the running instance. Of course this will not work because Skype will not let you sign in: Another instance of Skype may be running.

How do I refocus/bring to the foreground the existing Skype instance? In Windows, you can restore running instances through the taskbar. I've tried cycling through open windows, but the running instance window is no where to be seen.

share|improve this question
1  
This is basically a duplicate of this question, but the solution here might be a better workaround for you. –  Tom Brossman Feb 16 '12 at 15:46
add comment

4 Answers

up vote 1 down vote accepted

It would help to know what version of Ubuntu you are using but Skype has support for the system tray in the menu bar so you might see there a small skype icon. Click on that one and it will show you a huge menu with the option "Activate" which is "Open" in Skype language.

The system tray or top panel is this:

enter image description here

in this case I am using the default Ubuntu desktop (Unity from 11.10) and skype 2.2 Beta

Some settings that might affect this in Skype are:

enter image description here

  • Start Skype minimised in the system tray
  • Choose Style Also as mentioned in the comment above, when you have 2 or more opened skypes they will go crazy. To delete them all and start from the beginning go to a terminal and do this:

sudo killall skype

if that does not work do this: sudo killall -9 skype

if that still does not work do this: ps -e| grep skype a process for skype will appear with a number like for example:

5859 ? 00:00:11 skype

take that number and do this: sudo kill -9 5859.

Various ways to kill a process. Then just open Skype again.

share|improve this answer
    
I'm using the latest Ubuntu. I downloaded it a few days ago from Ubuntu's website. I imagine it's the latest stable version. How do I access the system tray? If it is what I think it is, there is not reference to Skype there. –  Mohamad Feb 16 '12 at 16:13
    
Updated to mention the system tray thingy and also to mention some of the settings of Skype that might affect this. –  Luis Alvarado Feb 16 '12 at 16:28
1  
Thank you. This is really helpful. Unfortunately my system try does not display the Skype icon. I think it might be a version issue. Regardless, I have a way to refocus the screen. –  Mohamad Feb 16 '12 at 16:43
    
If it helps I have 2.2.0.35. –  Luis Alvarado Feb 16 '12 at 16:55
add comment

I had this problem too. No matter how I set the Skype settings, it would not show in the taskbar. I tried whitelisting it too, but that did not work. What did work (though possibly in combination with whitelisting - I did not try it without) is a solution found in another askubuntu thread.

sudo apt-get install sni-qt:i386

Follow the link for more details on the matter.

share|improve this answer
add comment

I am unable to get the skype icon on the system tray as well.

However, there is a workaround which partly works for me.

In Ubuntu 12.4 LTS, You can lock Skype icon to the launcher. The icon stays there. When you click on it, it shows the currently running instance. If skype is not running, it starts the application.

I would still like to have it in my tab switcher.

share|improve this answer
add comment

In Unity, by default only certain applications are allowed to put icons into the panel. You can allow Skype's notification icon to appear by modifying the config.

The easiest way to do this is to use dconf-editor from the dconf-tools package. Use the tool to browse to desktop...unity...panel and change systray-whitelist parameter to ['all'] . This will allow all icons to show. Alternatively, you could add 'skype' to the list.

However, I still have a problem where Skype sometimes manages to hide itself completely, in spite of appearing in the panel to begin with.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.