Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Ubuntu 11.10 in my compaq nx6120 laptop. I turn on the wifi but it says "wireless disabled by hardware switch."

Is this a driver problem or is there any switch in laptop for enabling it? Please help

output of some commands are given below

$ sudo lshw -C network**

*-network:0 DISABLED    
       description: Wireless interface
       product: PRO/Wireless 2200BG [Calexico2] Network Connection
       vendor: Intel Corporation
       physical id: 4
       bus info: pci@0000:02:04.0
       logical name: eth1
       version: 05
       serial: 00:12:f0:99:dd:dc
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.5.27 (Dec 12 2007) latency=64 link=no maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
       resources: irq:21 memory:d0000000-d0000fff
  *-network:1
       description: Ethernet interface
       product: NetXtreme BCM5705M_2 Gigabit Ethernet
       vendor: Broadcom Corporation
       physical id: e
       bus info: pci@0000:02:0e.0
       logical name: eth0
       version: 03
       serial: 00:14:38:00:ea:cb
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 66MHz
       capabilities: pm vpd msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.119 duplex=full firmware=5705-v3.24 ip=192.168.1.3 latency=64 link=yes mingnt=64 multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:16 memory:d0020000-d002ffff

I am a beginner please help.

share|improve this question
add comment

2 Answers

The model of laptop you have has a hardware switch that can be toggled to turn the wireless function on and off - it also has a LED on it to indicate status.

It is located on the top edge above the keyboard - third button along from the left hand side.

Here is an image that should help you locate it.

share|improve this answer
    
thanks mark for replying.. but i have switched on that wireless button shown in the fig but it still showing "wireless disabled by hardware switch". If i need to install drivers for it pls tell me how to do it? thanks agaun –  krishna Feb 16 '12 at 13:33
    
hey good news .. now its working in my laptop " rfkill unblock all " works for me –  krishna Feb 16 '12 at 16:06
add comment

Try shutting down(if not already off), disconnecting the power, remove battery(if it is a laptop), press power a few times to release stored energy, reinsert battery(if it is a laptop), reconnect AC power. Turn on computer. Worked for me. After trying multiple fixes I found on the internet I remembered reading this somewhere. My hardware was blocked via a hardware switch(fn+f8) which doesn't work in ubuntu(works with windows, but uninstalled windows). rfkill showed 0: phy0: Wireless Lan as Hard Blocked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.