Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Firefox working with the debug flash player that I downloaded from Adobe Flash Player Support Center following the instructions on http://ubuntuforums.org/showthread.php?t=1300563. However, today, an automatic update came into my Ubuntu 11.10, which upgraded the flash player to 11.1.102.62 (a non-debug version).

When I copied the debug flash player again per instructions in the ubuntuforms link, flash does not work anymore.

I guess that the problem might be related to this bug: https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/870835

If they are now using the 64-bit flash plugin, it would make sense that the 32-bit debug flash player (There is no 64-bit debug flash player for the moment) does not work.

Is there anybody who knows how to work around this so I get the i386 plugin back with the nspluginwrapper?

share|improve this question

3 Answers 3

up vote 5 down vote accepted

I found the workaround:

First install the 'nspluginwrapper':

sudo apt-get install nspluginwrapper

or Using Software Center Install nspluginwrapper via the software center

Then copy the debug player to the correct location:

sudo cp ~/Downloads/libflashplayer.so /usr/lib/flashplugin-installer/

Next, call nspluginwrapper:

sudo nspluginwrapper -i /usr/lib/flashplugin-installer/libflashplayer.so
share|improve this answer
    
Thank you, this has been driving me crazy –  qualidafial Jul 9 '12 at 15:53

Ugh. Not enough rep to comment yet...

For anyone following these instructions who gets the following error:

nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-debugger/libflashplayer.so

Make sure you also sudo apt-get install ia32-libs

Anybody trying to run 32 bit software on a 64 install probably already has them, but I've been trying to keep my machine clean, and didn't have them yet.

Perhaps one of the other two duplicate answers can update to include ia32-libs.

Also, an upvote so I can comment instead of this extra post would be nice. Thnx.

share|improve this answer
    
Still getting an error "nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so" –  Installero Dec 26 '12 at 18:50
    
Did you try following the install instructions of the accepted answer? If so, did nspluginwrapper return success or do nothing? Please post more details of what you've tried so we can help you further. –  Ajax Dec 30 '12 at 11:41

Thanks, it worked OK on my box. To summarize this was my process:

  1. Install flashplugin-installer package (not adobe-flashplugin)

    sudo apt-get install flashplugin-installer
    

    or using Software Center Install via the software center

  2. Run this (as in previous post):

    sudo apt-get install nspluginwrapper
    sudo cp ~/Downloads/libflashplayer.so /usr/lib/flashplugin-installer/
    sudo nspluginwrapper -i /usr/lib/flashplugin-installer/libflashplayer.so
    
share|improve this answer
    
Thanks for confirming this. –  Wim Deblauwe Feb 20 '12 at 7:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.