Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had some issues with installing Lazarus in 10.04. After I finally installed it with aptitude, while running it prompted whole bunch of errors. Finally my PC was suspended and I had to reset it. After that my ethernet doesn't work. In my file

/etc/network/interfaces

there is only

auto lo
iface lo inet loopback

no sign of eth0. Many of possible solutions don't work. Unfortunately I cannot give the full output of

sudo ifconfig -v -a

or

sudo lshw -C network

because I am writing this post using my spartphone. The fact is that the first shows my eth0, and the latter gives:

*- network DISABLED
description: Ethernet interface
product: RTL8111/8168B PCI Express  Gigabit Ethernet controller.

Reinstalling drivers didn't change a thing. How can I run the same procedure that detects connection during Ubuntu installation process? I suspect that it could solve the problem.

Thanks

share|improve this question

2 Answers 2

up vote 3 down vote accepted

first see if you can see the eth0:

:~ # ip link list

maybe you can see something like this?

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 48:5b:39:f0:67:8f brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 54:e6:fc:81:f6:8a brd ff:ff:ff:ff:ff:ff

then add an ip to the eth0

:~ # ifconfig eth0 <yourip> netmask 255.255.255.0 

and add a default gateway

 :~ # route add default gw 10.100.202.2

or or you can edit your /network/interfaces (vi /etc/network/interfaces) to have in dhcp mode...

auto eth0
iface eth0 inet dhcp

somebody please emprove my poor english =D

share|improve this answer

maniat1k's answer is very good, however I found simplier one:

sudo dhclient eth0

however it should be added to some starting script :]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.