Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Lubuntu 11.10 (LXDE based on Ubuntu 11.10). A few days ago, I installed the Macbuntu, but it isn't compatible with LXDE and so, I uninstalled it. And today I installed Compiz (I have tried to install Compiz in Lubuntu 11.10 before and everything goes well at that time). I tried to run Compiz with the command compiz --replace and everything seems ok. But after a short time (usually within three minutes), the title bar and taskbar disappeared suddenly, and I cannot open any program with the hot key (e.g. I usually open the terminal with Ctrl+Alt+T, but it doesn't work at that time).

I can do nothing but kill the Xorg and stop the Compiz in tty1. Now the system is fine without Compiz. But when I try to run Compiz, the horrible thing will happen again. and I noticed that, usually when I close a window, or change the configuration of Compiz, the title bar would disappear suddenly. I really don't know how I can fix it. Can anyone give a hand to me?

Another: i have run gtk-window-decorator --replace to start the window decoration, i got the error:

Failed to load theme "Ambiance": Failed to find a valid file for theme Ambiance


(gtk-window-decorator:3994): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE
share|improve this question
    
I have that problem too but when I press Ctrl+Alt+Del and log out and then log back in, everything goes right. The title bar disappears only when I change my desktops. How many desktops do you have in Compiz general settings? –  geoh Feb 16 '12 at 10:01
    
possible duplicate of Enabling Compiz Disables Windows Title Bar - Why? –  jokerdino Feb 16 '12 at 10:22
    
i have looked through the question you referred to. but nothing help. @jokerdino –  MarkZar Feb 16 '12 at 10:41

3 Answers 3

up vote 0 down vote accepted

maybe it has some connection with some animation adds-on, such as beam, when open those special effects, compiz will crash. though i didnt know why

share|improve this answer
    
Try emerald it may help you –  Tachyons Feb 17 '12 at 1:04
    
thx, i have installed it. now everything goes fine without such crash animation(e.g. beam .etc), just leave it at that :) –  MarkZar Feb 17 '12 at 2:59
    
@MarkZar - please add what you have done as an answer and accept it by clicking that tick button so that the question can be closed. thanks. –  fossfreedom Feb 17 '12 at 14:14

Try to run compiz setting manager than(you can run it from terminal typing ccsm). Than enable than disable Windows Decoration than restart your computer.

share|improve this answer

The way I managed to fix this was to get in the compiz setings manager and put put to default all the options for the Windows Decoration, the command line got updated. I then rebooted and it seems to have fixed the issue.

The symtoms for me were: Windows Decoration dispparearing every time I did a minimize and restore.

I'm running Ubuntu though, I don't know if that'll fix your case. I had a similar issue in the pass which running "gtk-window-decorator --replace" at start up fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.