Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After connecting my computer to the corporate network I don't have direct Internet access. This is done now through some proxy server. I can connect to the Internet from Firefox by the following way:

Preferences - Advanced - Network - Connection - Settings - Automatic proxy configuration URL: http://some_path/some_file.pac

So, Firefox is OK. But all Install/Update functions don't work. For example, this is Synaptic Package Manager error message:

The repository may no longer be available or could not be contacted because of network problems.
Failed to fetch http://il.archive.ubuntu.com/ubuntu/dists/lucid/Release.gpg  Something wicked happened resolving 'il.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Failed to fetch http://il.archive.ubuntu.com/ubuntu/dists/lucid/main/i18n/Translation-en_US.bz2  Something wicked happened resolving 'il.archive.ubuntu.com:http' (-5 - No address associated with hostname)
...

It looks like I need to explain to my OS, how to connect to the Internet. How can I do this? Ubuntu version is 10.04.

Edit: After setting Network Proxy, as described in kingmilo's answer, I still have the same problem. For example:

alex@alex-ubuntu:~$ sudo apt-get install execstack
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.32-21 linux-headers-2.6.32-21-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libelfg0
The following NEW packages will be installed:
  execstack libelfg0
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 134kB of archives.
After this operation, 410kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  libelfg0 execstack
Install these packages without verification [y/N]? y
Err http://il.archive.ubuntu.com/ubuntu/ lucid/main libelfg0 0.8.13-1
  Something wicked happened resolving 'il.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Err http://il.archive.ubuntu.com/ubuntu/ lucid/main execstack 0.0.20090925-1
  Something wicked happened resolving 'il.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Failed to fetch http://il.archive.ubuntu.com/ubuntu/pool/main/libe/libelf/libelfg0_0.8.13-1_i386.deb  Something wicked happened resolving 'il.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Failed to fetch http://il.archive.ubuntu.com/ubuntu/pool/main/p/prelink/execstack_0.0.20090925-1_i386.deb  Something wicked happened resolving 'il.archive.ubuntu.com:http' (-5 - No address associated with hostname)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Edit 2.

nslookup www.google.com
Server:     10.192.188.72
Address:    10.192.188.72#53

** server can't find www.google.com: NXDOMAIN
share|improve this question

2 Answers 2

Go to System Settings | Network | Network Proxy and Apply System-Wide, that will configure Ubuntu to use the corporate proxy for Internet access across all applications.

If you would like to set the proxy explicitly for your console session, ie. the terminal window you are currently using you can use the export command:

export http_proxy="address:port"

Hope this helps.

share|improve this answer
    
Thanks. Now Synaptic Package Manager shows full program list, but attempting to install any program still fails with "No address associated with hostname" error. I added some details to the question. –  Alex Farber Feb 16 '12 at 11:09
    
Alex, are you able to resolve say, www.google.com from the command line # nslookup www.google.com It looks like your DNS is failing to resolve the il.archive.ubuntu.com so have you set your DNS accordingly? - milo –  kingmilo Feb 16 '12 at 11:53
    
kingmilo: see nslookup results in the answer. –  Alex Farber Feb 16 '12 at 12:23
    
Alex, ok so you cannot resolve hostnames, do you have any DNS set? From the command line # cat /etc/resolv.conf You should get something back, if not then you need to specify the DNS in Network Manager for the device you are using to connect, wireless or ethernet, let me know if you need help with this. –  kingmilo Feb 16 '12 at 13:24
    
This file is empty. I am waiting for additional information from our network administrator, and then I will try your http_proxy suggestion. Thanks. –  Alex Farber Feb 16 '12 at 14:50

Put your proxy settings into Synaptic.

Settings -> Preferences -> Network -> Manual proxy configuration.

Enter the .pac in HTTP proxy, and you will probably have to put the right port and authentication details in too.

share|improve this answer
    
Thanks, I will ask the port number from our system administrator, and then I will try this. –  Alex Farber Feb 16 '12 at 12:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.