Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On version 11.04 Ubuntu I have access to my Wifi, but after I upgrade to 11.10, I can never get wifi at all. If I'm wired then it works, but if I'm not then it doesnt work.

share|improve this question
    
Welcome to Ask Ubuntu! This is a known bug, please see:bugs.launchpad.net/ubuntu/+source/linux/+bug/907657. There is a solution listed there. –  William Feb 16 '12 at 6:22
add comment

3 Answers 3

For 12.04 and 11.10

I had the same problem with the same computer enter these commands and it will be solved.

sudo modprobe -r iwlagn
sudo modprobe iwlagn bt_coex_active=0

If it worked you need to make it permanent.

To make the change permanent:

gksu gedit /etc/modprobe.d/iwl.conf

Copy/paste this line into the new file:

options iwlagn bt_coex_active=0

Save and quit.

After you do this you will experience very slow internet connection but it can be solved by making iwlag not use n and it can be done with these commands.

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1

if you see it made a difference once again you must make it perminent..

gksu gedit /etc/modprobe.d/iwlagn-disable11n.conf
options iwlagn 11n_disable=1

Save and quit. And thats all

Thank you WBMachinery for this.

Bug report:

share|improve this answer
add comment

I arrived here trying to find out why the broadcom wireless in my acer aspire laptop was performing slowly. The originally proposed fix on the fedora bug worked for me:

Please create a file called /etc/modprobe.d/iwlwifi.conf with a single line like this:

options iwlwifi 11n_disable=1

Then reboot (or "modprobe -r iwlwifi ; modprobe iwlwifi" as root).

I also had to rmmod brcmsmac, which is the broadcom specific bit, so pay attention to your module dependencies.

share|improve this answer
add comment

found this buried deep in bug report:

create /etc/modprobe.d/iwl.conf with the following:

#!/bin/sh
options iwlwifi bt_coex_active=0

or

#!/bin/sh
options iwlagn bt_coex_active=0

the second one worked for me

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.