Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running ubuntu 10.10 and my soundcard is a realtek alc880, with intel HDA controller. I have a very low sound, and, when I raise the volume over 50%, it sounds "cracked". When I plug the headphones in, it keeps on playing through the speakers (and the headphones don't play any sound). In windows, it sounds fine, and the headphones work well. Please help!

share|improve this question
    
As mentioned in my comment below, first please test a daily build of the sound driver. If you're still experiencing the problem, please use ubuntu-bug alsa-base. –  Daniel T Chen Nov 27 '10 at 15:39
    
@Stefano Palazzo I know, it's mine, but since i'm on a different user i can't edit it and i wanted to ask it clearer. –  wifi Jan 19 '11 at 17:10

10 Answers 10

Run alsamixer -c 0 in your console and use the arrow keys to play around with the volumes.

For me: Setting Master to a value where the sound quality was good enough made it very very low. Setting Master to maximum, decreasing PCM to 81 and setting everything else to 0 fixed the problem.

UPDATE: (for Ubuntu 10.10) Click on the volume icon in the upper-right corner, then click on Sound Preferences, and make sure that the Output volume doesn't go above "Unamplified." Then, click on the volume icon again and see where the volume meter is positioned. That is the maximum volume you should set in order to hear a clear sound.

OR: (for Ubuntu 10.10) Click on the volume icon in the upper-right corner, then click on Sound Preferences, set the main volume to 100% and set the volume for each application to a more appropriate level. Each time you open an application that needs to use sound for the first time, you have to do this (because applications that don't currently use sound don't appear in that list).

You currently have to choose between annoying and complicated :(

share|improve this answer

i suggest you to use pulseaudio system wide equalizer.

  • Ubuntu Lucid User

PPA

sudo add-apt-repository ppa:psyke83/ppa

Then install by typing

sudo apt-get update && sudo apt-get install pulseaudio-equalizer
  • Ubuntu Maverick User

You have to install it manually by downloading .deb file below,

Pulse Audio Wide Equalizer ==> for both 32bit and 64bit

share|improve this answer
    
alright, i've just installed it. what now? –  alex Nov 12 '10 at 19:17
    
what the? when i enable the EQ, the sound stops working... –  alex Nov 12 '10 at 19:29

I had exactly the same problem and this is how i made it work

http://ubuntu-ky.ubuntuforums.org/showpost.php?p=10050353&postcount=16 and here is the general link as given in the above link https://help.ubuntu.com/community/HdaIntelSoundHowto

share|improve this answer
    
hey, it got a little better! thanks. –  alex Nov 12 '10 at 19:34
    
but, how come this does work if my computer isn't a thinkpad? –  alex Nov 12 '10 at 19:35
    
and the headphones still don't work... –  alex Nov 12 '10 at 19:39

I would look at the mixer first. Right click on the sound icon in the notification area. I use Kubuntu, so am not sure of the exact terminology. It will be at the bottom of the drop down. In Kubuntu it is show mixer window, but it will be similar. Then check the sliders and muted boxes. Uncheck ones that affect your headphone jack and slide the slider farther forward for your master volume.

share|improve this answer
    
thanks, but didn't work. –  alex Oct 30 '10 at 17:59
    
Try running alsamixer in the terminal, you might just have to mute the front channel manually when you plug headphones in. Play with those a bit. –  NightwishFan Oct 30 '10 at 18:02
    
didn't work, thanks anyway. –  alex Oct 30 '10 at 19:27
2  
This means your card is not supported then. Try updating alsa by adding this ppa. launchpad.net/~ubuntu-audio-dev/+archive/ppa –  NightwishFan Oct 30 '10 at 20:18
    
adding this and updating will upgrade tha alsa drivers? –  alex Oct 30 '10 at 21:37

There are some solutions for the Intel HDA sound controller on ubuntu community documentation. At the end of the page there is a tip about getting the driver from realtek site.

share|improve this answer
    
doesn't work, but thanks –  alex Oct 31 '10 at 10:55

Intel HDA has a lot of problems. Getting it to work (from what I've seen and experienced) is hit or miss. The kubuntu user is right about your volume mixer, which you may have to configure to show all options (slider controls). For me it was bringing Headphone jack sense into the mixer and enabling it. (It was disabled by default.)

share|improve this answer

Have you tried fiddling with alsamixer in the terminal? If turning up the volume makes the quality terrible then your PCM values may be way too high.

share|improve this answer
    
yes, but that makes the sound volume too low. –  wifi Jan 22 '11 at 13:56
    
I've been through that road before, too. I think it's just bugs in your alsa drivers. It's just finding the perfect balance between actual volumes and the PCM volumes. –  user6658 Jan 22 '11 at 16:04

For these types of problem there are specific steps to follow,

  1. Obtain the full technical information of your system by following the commands at https://wiki.ubuntu.com/DebuggingSoundProblems and performing the rest of the steps. You can also obtain the information about alsa-info.sh (see previous URL for more), which will helps us to direct you from here.
  2. Install the latest Alsa packages according to the instructions at https://help.ubuntu.com/community/HdaIntelSoundHowto Then reboot. In this way you will get the latest Alsa code which may include better support for your sound card. This is an easy way to try to fix if you do not want to read much.
share|improve this answer

If you have windows installed be sure this is not set to mute. I just find out this was the problem, why skype with headphones didnt work. Also set skype, in options, not to adjust the sound, and turn the input sound in sound preferenses to the highest lewel.

share|improve this answer

Gnome ALSA Mixer : reducing PCM makes quality

share|improve this answer
    
if i do that, the sound gets too low to be heard –  alex Oct 30 '10 at 21:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.