Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In windows, most laptops these days have a hot-key to turn off wireless modules completely (i.e. airline mode), including WLAN and Bluetooth. I am currently on Ubuntu 11.10, and wondering as to what is the way to have the same effect, i.e. make sure that those modules are electrically off - not consuming any power, and the radio beacon is off.

share|improve this question
    
I believe hardware buttons work the same way in Ubuntu. Something like Fn-F5 or special "wifi" button etc. –  Sergey Feb 16 '12 at 5:12
    
The problem in my case is that the hardware buttons never worked. I am using a Compaq Presario CQ42 laptop, and never managed to find the scripts that'd get the hardware hot-keys to work. This means, I do not have screen backlight control, touchpad control, wireless control, volume control etc., any of it working ! :-( –  icarus74 Feb 16 '12 at 5:53
    
Well, from my experience the buttons usually do work out of the box - it must be something with Ubuntu on your particular laptop model. I'm just trying to clarify - your question sounds a bit too general. –  Sergey Feb 16 '12 at 6:40

2 Answers 2

up vote 2 down vote accepted
  1. Press F10 right after turning the laptop on to enter BIOS settings.
  2. Go to the "System Configuration" tab.
  3. Disable Action Keys.
  4. Save and Exit.

This should solve the problem. Now, when you press F1-12, It will activate the function (wireless, etc.). To access the F-keys normal functions ans function keys, press and hold Fn and then press the key. Hope that helps!

share|improve this answer
    
Thanks. Part success, but I had to 'Enable Action Keys' in BIOS, not the other way around. Not sure if it was a typo, or I misunderstood. Now, I can at least see that the on-key LED change from White to Red and back. After enabling 'Action Keys' in BIOS, LCD backlight works, but screen-blanking, volume-control, and other music-control (which I actually have no use of), still don't work. Does it require some extra configuration or additional software to be installed ? –  icarus74 Feb 16 '12 at 6:44
    
Yep, typo. Sorry about that. As far as the volume and music controls. etc. Unfortunately, the volume and music controls are Windows functions that require Windows drivers. You can try looking at the configuration in System Settings -> Keyboard Shortcuts and seeing if it is possible to assign the keys. But, if it doesn't work there, your'e out of luck. –  William Feb 16 '12 at 20:06

I use rfkill for this. Here's the online man page that gives you the package name and other miscellaneous data.

share|improve this answer
    
Thanks. A "rfkill list" shows 3 interfaces -- hp-wifi (Wireless LAN), hp-bluetooth (Bluetooth), phy0 (Wireless LAN), and each one of them seems to be Soft-blocked:NO and Hard-blocked:YES. Wondering why it shows 2 Wireless LAN interfaces. I do not have any USB WiFi (additional WLAN) interfaces. –  icarus74 Feb 16 '12 at 8:02
1  
It's weirdness with the hp wireless driver. My laptop does the same thing. I'm speculating, but hp-wireless could be the controls for the buttons that control wireless. phy0 is the raw card. –  hbdgaf Feb 16 '12 at 18:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.