Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I enable touch pad gestures(multi touch effects) of alps touch pad which comes with dell inspiron n5110 in ubuntu 11.10. These gestures worked fine with windows.

share|improve this question
    
possible duplicate of Enable two-finger scrolling on ALPS touchpad –  michaelms Feb 28 '12 at 4:16
1  
Here you can find a solution: askubuntu.com/a/199587/44254 –  Beni Bogosel Oct 23 '12 at 15:35

2 Answers 2

This blog post contains instructions for installing patched mouse drivers, which enable correct recognition of your touchpad: http://nwoki.wordpress.com/2012/10/02/multitouch-fix-for-alps-touchpad/ Even this is a little outdated, as there have been several updates to the drivers since.

In short: Download psmouse-alps-1.3: http://www.dahetral.com/public-download/psmouse-alps-1.3.tbz/view Then (using sudo / root):

  • Extract the folder psmouse-alps-1.3 to /usr/source
  • cd to /usr/source
  • dkms add psmouse-alps-1.3
  • dkms autoinstall
  • rmmod psmouse && modprobe psmouse

Bam! Working multitouch! :-)

Possible duplicate: Enable two-finger scrolling on ALPS touchpad

share|improve this answer
    
tried.... bt nt wrkng –  chathurawidanage Mar 5 '12 at 16:40

If you want to enable your Dell Inspiron 15R Touchpad:

  • download that alps-dkms package and install it in /usr/src.
  • from a terminal, navigate to /usr/src/psmouse-alps-0.10/src and then gedit alps.c
  • in alps.c scroll down and copy the /* Dell Vostro 1400 */ line completely. In that line you will have to replace first 3 matches, that is , replace 0x73 , 0x02 , 0x50 with 0x73 , 0x03 , 0x50 .
  • Save the file and return to the terminal. In the terminal type dkms add -m psmouse -v alps-0.10
  • After this, type dkms build -m psmouse -v alps-0.10
  • after build is complete, install it with dkms install -m psmouse -v alps-0.10
  • after it installs it successfully, type rmmod psmouse && modprobe psmouse This will reload your psmouse module.
  • Next, type xinput --list to see whether it loaded successfully or not. If it shows Alps/PS2 Alps GlidePoint in the xinput , than congrats. And i bet it will show as i got it working by this! If you need complete patched module , you can ask me :)
share|improve this answer
    
tried everything but not working.... :-( –  chathurawidanage Mar 5 '12 at 16:40

protected by Community May 16 '12 at 1:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.