Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Ubuntu on my computer, but I don't use Ubuntu anymore.

I still have the Ubuntu option on my computer's boot menu in UEFI.

How do I delete this crappy useless boot option with Windows and without Linsucks?

share|improve this question
add comment

2 Answers 2

Step 1 Insert Ubuntu live CD or Ubuntu Bootable USB .Restart and boot into ubuntu live session.

Step 2 Open Terminal and type
sudo apt-get update
sudo apt-get install efibootmgr

Step 3 Don’t close terminal type following cmds to remove bios boot menu entry. sudo efibootmgr you will able to see different menu entries.Look for menu entry with name ”ubuntu” or
“linuxmint” and see last number or character before * sign next to boot name.
for example: my bios boot menu entries were

Boot000A* ubuntu

Or

Boot0009* linuxmint

Type in terminal to remove these entries
for me it is 9 for you it can be any other  number

sudo efibootmgr –b 9 –B

if it is a alphabet
sudo efibootmgr -b A –B

Done . Hooray !! :)
type sudo efibootmgr -v in terminal to crosscheck.

If you don't see the entries ubuntu or linuxmint  you have successfully removed them  from boot menu .

share|improve this answer
add comment

download and install easyBCD non commercial version. Here is the link

Here you can edit the boot menu easily.

If you have installed ubuntu in a seperate ext4 parttion.. first delete that partition using windows(right click my computer and click manage) Then restart your computer using a windows7 DVD. use recovery options to fix MBR

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.