Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have downloaded *.deb files from Lazarus homepage and used

sudo dpkg -i *.deb

in Lazarus folder. It did install, but couldn't run due to error saying:

No Lazarus executable in usr/lib/lazarus/

So I removed it, and tried to install Lazarus from software manager and with

sudo apt-get install lazarus

Both with no success. I get following error (translating to english):

lazarus: requires: lazarus-ide (>=
E: Packages are damaged

What should I do?

Thanks in advance, Regards

share|improve this question

1 Answer 1

I found a workaround for the first problem:

No Lazarus executable in usr/lib/lazarus/

Install Lazarus from website ( download site), I also installed fpc.

Go to


and run file


instead of


IDE runs without problem.

PS.: sysinfo - Ubuntu Lucid 10.04 x64


However after that, apt-get stopped working due to unresolved dependencies. So really I had to remove this version of Lazarus. I had huge issues with installing Lazarus from USC, finally aptitude instead of apt-get managed to install it, but it worked improperly. Due to some error I lost my ethernet connection. After restoring my ethernet connection I uninstalled Lazarus using aptitude and installed it from USC and now it works fine :]

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.