Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After running a system update I got this error when I wanted to save a screen shot to my desktop:

Impossible to save the screenshot to file:///home/tinuz/Pictures. Error was

GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/bin/nautilus received signal 6.
 Please choose another location and retry.

It tells me to save it to another location but when saving to another location I get the same error message. Please let me know how to fix the problem.

Thanks in advance tinuz

Just got home and here is the output:

tinuz@PC1-1110:~$ id; ls -ld /home/tinuz/Pictures; ls -ld /home/tinuz; ls -ld /home

uid=1000(tinuz) gid=1000(tinuz) groups=1000(tinuz),4(adm),20(dialout),24(cdrom),46(plugdev),116(lpadmin),118(admin),124(sambashare)
drwxr-xr-x 4 tinuz tinuz 4096 2012-02-14 21:25 /home/tinuz/Pictures
drwxr-xr-x 49 tinuz tinuz 4096 2012-02-15 18:24 /home/tinuz
drwxr-xr-x 3 root root 4096 2012-01-29 22:07 /home
share|improve this question
(1) Edit your question and provide the output of these commands. They'll show your username, groups and folder permissions: id; ls -ld /home/tinuz/Pictures; ls -ld /home/tinuz; ls -ld /home (2) Did you try some other folder? – medigeek Feb 15 '12 at 7:44
Thanks for your reply... I did try to save to another folder/location and still have the same error message. I can save files but the problem only occurs when i want to save a screen shot. I have to try the command line when i'm back home and will let you know the output. – tinuz Feb 15 '12 at 8:09
Try creating a new user. If it works there, it's either some file permissions problem or a configuration option in your home folder (hidden files). – medigeek Feb 15 '12 at 21:20
By the way, are you using gnome/unity/ubuntu, xfce/Xubuntu or lxde/Lubuntu? – medigeek Feb 15 '12 at 21:23
I'm using Ubuntu 11.10 and creating a new user didn't work and the problem isn't solved. – tinuz Feb 16 '12 at 6:39
up vote 1 down vote accepted

Based on the comments above, sounds like a program (file permissions or otherwise) problem. Unfortunately, in this case, I would backup my important data and just reinstall the root (/) partition.

If you enabled any PPA or other third-party repositories, please don't, they're not all safe, unless you're 100% sure they work. Sometimes they exist in order to test packages.

Alternatively, you can always:

  1. use the command import from package imagemagick
  2. install gimp and from the menu File > Create > Screenshot
share|improve this answer
The only way to save the screen shot is by making it, copy it to clipboard and then open gimp and paste it into gimp and from there i can save it to my desktop or any other folder/location. Thanks for your help, not sure what causes the problem but it's a nasty problem. – tinuz Feb 17 '12 at 8:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.