Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a regular update of Ubuntu 11.10 yesterday night and it didn't require a restart.

After the update finished I still had connection (wired). But, today, when I tried to go to Google and other sites, there was no connection. Network manager is installed and it said no connection found. I've checked the cable and nothing seems to be wrong.

How can I get my connection back? It works fine on Windows (from which I'm writing this).

share|improve this question

closed as too localized by jrg Dec 30 '12 at 1:44

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
In my case, running an ifconfig only shows the lo0 interface up. when i had ubuntu 11.04 server, networking started automatically, i did the "upgrade" and now i only get the waiting additional 60 seconds for networking warning.... i have to login and get the sudo -i prompt in order to manually configure networking AND dhcp... I read it is a bug related to 11.10 upgrades that doesnt appears when you do a clean install. Seems that 11.10 is expecting the /var/run and /var/lock files to be in /run and /run/lock folder, but althought i did move the folders and created a simbolik -s link as describe –  user46505 Feb 15 '12 at 11:25

2 Answers 2

This might seem stupid, but it worked in my case once: Shut down, power off router, unplug the power cord of the tower and the router. Then wait for 1-2 minutes, plug it back in, power on.

share|improve this answer

Is your IP address to your computer static or configured by DHCP? Whats the contents of the file /etc/network/interfaces say?

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.