Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just got a new Ubuntu 11.10 install working. Updated my software and rebooted, but now when I try to log in, I'm greeted with the following error:

could not connect to session bus: //bin/dbus-launch terminated abnormally without any error message

Any ideas?

Thanks.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

That's a very weird file path //bin/dbus-launch - that should've been /usr/bin/dbus-launch. Does the system hang there or does it allow you to go further?

Have you tried searching for that path in your home? This will go through your files/documents in home and echo the filename that contains "dbus-launch":

grep -ri dbus-launch /home/myusername

Also try creating a new user.

  • Press CTRL+ALT+F1 - this will get you in the console. Login with your credentials.
  • Execute:

     sudo adduser mynewuser
     sudo adduser mynewuser admin
    

    It will ask for a password twice, type it in. You can leave the rest of the fields empty (full name etc.), just press enter. The second command will add you as administrator.

  • Now restart your lightdm (desktop manager): sudo service lightdm restart

If the new user works, then it's definitely a problem in your home folder (probably hidden folder settings, press ctrl+H in nautilus to show hidden files/folders).

share|improve this answer
    
I ended up doing this. Thanks! –  Paul Mar 2 '12 at 6:24

I have also this error because I change text in file .profile

So get to Ubuntu I use tips from: http://www.89geek.com/2012/01/fix-ubuntu-could-not-connect-to-bus.html

good luck!

share|improve this answer

I received this error when I modified the /etc/environment file and changed the PATH variable.

I went to this to solve the problem.

On the login screen Press CTRL+ALT+F1, then type in your regular name and password.

If you get something like "/bin is unavailable" because it's not included the PATH environment then you need to go to you /etc/environment file and see if it looks like this

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"

I had extra lines because I was trying to add java to the path

If you type in

export PATH=/usr/bin:/bin

you will be able to us the ls command but that will only be for this login session

I edited that file with the pico editor

sudo pico /etc/environment

saved it, logged out and the pressed CTRL+ALT+F7 to get back to the graphic log in and was able to log in.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.