Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can i disable ALL pop-up notification on Xubuntu 11.10

I have tried: sudo apt-get remove notify-osd

Which resulted in

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package notify-osd is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
share|improve this question
add comment

2 Answers

Obviously removing notify-osd won't work because Xubuntu doesn't use it, it uses xfce4-notifyd.

So if you want to remove them, remove that package.

 sudo apt-get remove xfce4-notifyd

If you only want to disable them use this:

 sudo mv /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service.disabled

To reverse that:

 sudo mv /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service.disabled /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service

Source.

share|improve this answer
    
Awesome! thanks! but now sound +/- buttons on keyboard do not work! (( –  craizzz Feb 14 '12 at 23:54
    
Well no, xfce4-notifyd works with xfce4-volumed.. –  Uri Herrera Feb 15 '12 at 1:36
    
I have install $ xfce4-notifyd –  craizzz Feb 15 '12 at 1:41
    
back and $ xfce4-volumed to but buttons still dose not work –  craizzz Feb 15 '12 at 1:42
    
If you remove the Notifications daemon the Volume daemon doesn't work. –  Uri Herrera Feb 15 '12 at 1:47
show 3 more comments

Try this:

sudo mv /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service.disabled
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.