Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 (32-bit) in VirtualBox 4.1.8.

I wanted to install Cinnamon, so I did and I have the option to choose it from the login screen, as well as GNOME options.

If I choose Ubuntu I get Unity, which works fine. GNOME also works. But when I choose Cinnamon, the screen goes black and nothing responds and I have to reset the virtual machine.

I have already installed Ubuntu 11.10 (64-bit) onto the PC in a separate partition (currently running 10.10 but trying out 11.10) and in that Cinnamon works perfectly. In VirtualBox I have 3D settings enabled and gave the virtual machine 128 MB graphics RAM, and 1024 MB system RAM.

What settings should I change or what should I do to get Cinnamon working in Ubuntu in VirtualBox?

I have also tried doing it in LinuxMint 12, but I get the same problem, just a black screen when selecting Cinnamon.

So are Cinnamon and VirtualBox incompatible?

share|improve this question
1  
what is your host graphics card (lspci | grep VGA) and are you using any graphics drivers? –  fossfreedom Feb 14 '12 at 20:03
    
Are you using the FGLRX/AMD/ATI drivers? –  MiJyn Feb 15 '12 at 0:33
    
Have you actually installed the Guest Additions? –  Uri Herrera Feb 15 '12 at 3:53
    
Since you're working with VirtualBox anyway, wouldn't it be easier to install LinuxMint directly on its own VirtualBox instance? –  Ken Feb 16 '12 at 3:41
    
@kavoura - I note you have edited your question by adding a ?. Please edit your question with the answers above. Thanks. –  fossfreedom Feb 17 '12 at 20:55
add comment

4 Answers 4

The forums suggest this isn't possible as of now:

Cinnamon doesn't run inside VirtualBox yet; version 1.5 will, but that is version 1.5

For now, you are stuck with Mate or Gnome Shell (I suggest you to Update Mate to version 1.4; it is way better than Gnome shell) and wait for Mint 13 to come out since Maya will have fixed Cinnamon to work with VirtualBox. Nothing to do until then. Sorry I can't be of more help.

share|improve this answer
add comment

To run Cinnamon in VirtualBox on Windows, I've had to check the PAE/NX in Processor tab in System settings.

share|improve this answer
    
Brilliant, thanks. Enabling PAE/NX allowed my ISO to boot and then enabling 3D acceleration prevented Cinnamon from crashing see @user65892 's answer below: askubuntu.com/a/162894/85213 –  Brett May 30 at 18:16
add comment

Cinnamon works (assuming your hardware isn't the issue). Go to the Display section under Guest OS Settings, and enable 3D Acceleration.

share|improve this answer
    
still doesn't work for me –  thelaststud Jul 28 '12 at 18:14
add comment

I know this is very old but I ran into this issue and fixed it by logging out in terminal $gnome-session-quit and then selecting cinnamon in the log in page.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.