Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do you configure Flash to not allow access to webcam and mic?

I'm currently primarily interested in this for Chrome, but if the solution is different for other browsers, please list it as well.

share|improve this question
    
You just made me crash my browser.... :-( –  JanC Oct 30 '10 at 11:07
    
@JanC: Ouch, how'd that happen? –  Roger Pate Oct 30 '10 at 11:19
    
I guess there is a good reason why I have Flash disabled normally... :P –  JanC Oct 30 '10 at 11:33
    
@JanC: The Flash plugin also crashed for me when I was experimenting with this on a YouTube video (the first place I thought of to load Flash)... but at least Chrome sandboxed it. :P –  Roger Pate Oct 30 '10 at 11:40

3 Answers 3

up vote 2 down vote accepted

Simply open the Macromedia settings manager and select "Always Deny" in the "Global Privacy Settings panel".

On a side note: this page is accessible from all browsers and those settings will be used by all browsers.

share|improve this answer
    
This is where you're taken when selecting the option JanC mentions, thanks. –  Roger Pate Oct 30 '10 at 11:32
    
(I'll have to wait until tonight to get more upvotes.) –  Roger Pate Oct 30 '10 at 11:33
    
I don't care about rep points. :-) As long the question is answered, everything's fine. –  htorque Oct 30 '10 at 11:36

(An expansion on JanC's answer which wouldn't fit in a comment.)

Right-click on a Flash applet and select "Settings..." to control just that site:

Flash settings screenshot

The "Global Settings..." option controls all sites. It appears disabling it globally still allows you to enable per-site, as that's what I did for the above screenshot.

share|improve this answer

There is an option in the right-click menu if you click on any flash applet that will bring you to a special applet on Adobe's site where you can configure that.

It also seems like the only options are "always deny" or "always ask"...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.