Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.
michael@Ubuntu:~$ sudo apt-get clean
michael@Ubuntu:~$ cd /var/lib/apt
michael@Ubuntu:/var/lib/apt$ sudo mv lists lists.old
michael@Ubuntu:/var/lib/apt$ sudo mkdir -p lists/partial
michael@Ubuntu:/var/lib/apt$ sudo apt-get clean
michael@Ubuntu:/var/lib/apt$ sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
michael@Ubuntu:/var/lib/apt$ sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.

Why am I getting these errors when doing an apt-get update?

share|improve this question
    
Please edit your question and the add the content of /etc/apt/sources.list file – jokerdino Feb 15 '12 at 13:49

Try:

sudo apt-get install apt-transport-https
share|improve this answer

I encountered this problem as well. I was unable to fix it by installing apt-transport-https, because it had been quite a while since I'd done any package updates on the machine in question, and the version of that package that I needed was no longer available in the package repository. (To get an available version, I first had to be able to apt-get update successfully.) Thus, I was forced to track down the reason why apt-get was suddenly trying to use HTTPS, and stop it from doing that.

In my case, it turns out that one of the third-party apt sources that was listed in a config file in my /etc/apt/sources.list.d directory had switched to using HTTPS for all downloads, and they had begun redirecting the http:// URL to an https:// URL. This was making apt attempt to use HTTPS even though none of my source configurations requested it. (I discovered this by opening the source repository URL in my web browser, and noticing that the URL in the address bar changed to https:// when the page loaded.)

Since this was a third-party repository and thus non-essential, I simply disabled that source temporarily, then reran apt-get update and it worked with no problem. After apt-get update, apt-get upgrade and apt-get install apt-transport-https, I was able to re-enable that third-party apt source, and from there on everything worked.

share|improve this answer
2  
Thank you for specifying sources.list.d/. It's been a while since I've worked with Ubuntu's various apt-related files, and that's what I needed to fix this issue. – Lyle Brown Jul 13 '15 at 6:33
1  
I'm glad this helped someone! I spent a long time tracking this problem down, so I was eager to share my findings. – Nate C-K Jul 20 '15 at 22:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.