Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm unable to install libboost-all-dev package versions 1.42 or latest in ubuntu 10.04. only boost1.40 is installing. but i need 1.42. what should i do? when i tried to install 1.48 boost i got the following error:

robotics@robotics-desktop:~$ sudo dpkg -i libboost-all-dev_1.48.0.2_i386.deb
Selecting previously deselected package libboost-all-dev.
(Reading database ... 224047 files and directories currently installed.)
Unpacking libboost-all-dev (from libboost-all-dev_1.48.0.2_i386.deb) ...
dpkg: dependency problems prevent configuration of libboost-all-dev:
dpkg: error processing libboost-all-dev (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libboost-all-dev

what should i do? should upgrade to 11.10?

share|improve this question
add comment

1 Answer

It says You need to install some more dependencies:

libboost-all-dev depends on libboost-dev; however: Package libboost-dev is not installed.

Try to find and install all listed dependencies using synaptic or apt-get. Sart with libboost-dev. However in 10.04 there is 1.40 version of Boost. Do You need some new features from 1.42 or 1.48? If not then use 1.40 provided by Ubuntu Software Center. If yes:

You can always compile Boost Yourself. On the boost website You can find step by step tutorial. Then You just have to remember to include proper headers.

I compiled Boost on Win and on Linux and it is not really painful :)

EDIT: In many cases You don't even need to compile Boost to use it, because it is include-header-only.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.