Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently just downloaded Ubuntu 11.10 and before I installed, wireless worked perfectly in Windows. Now that I have downloaded and installed Ubuntu, I no longer have Windows. I do not have a wired connection at my house, only a mifi, so my computer is useless now without internet.

I really like the functionality of Ubuntu, but need internet. I have already run the additional drivers page and it says it has installed the driver for my Broadcom wireless adapter and is working. The laptop has a Fn+F2 to turn on the wireless adapter when in Windows, but this does not work in Ubuntu.

I am new to Linux so I really need some help. Thank you all in advance.

share|improve this question
1  
More info is required. Check out the following link for guidance: askubuntu.com/a/61547/20054. Add the info to your question, don't post it in the comments. –  mikewhatever Feb 14 '12 at 7:42
1  
Try opening a terminal and typing sudo rmmod dell-laptop. See if the wireless enables after that. Please let me know if it works so I can provide a proper answer with an explanation of what the problem is. –  roadmr Feb 14 '12 at 19:45
    
When i type this, i get an error that states: module dell_laptop does not exist in /proc/modules –  Nick Feb 19 '12 at 17:15
add comment

1 Answer 1

up vote 0 down vote accepted

A solution to this problem that worked for me (Dell E1405, BCM4311, Ubuntu 11.10) can be found here:

http://nfolamp.wordpress.com/2011/10/15/ubuntu-11-10-getting-wireless-bcm4311-working/

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Feb 18 '12 at 23:07
    
Thank you very much. after trying this a few different times, i found there was one more command i needed to type into the terminal after the initial apt update to free it up. after doing the extra command, the list started taking longer to populate, and actually looked as if it was working. after i rebooted, the internet started working and now the fn f2 works like it is supposed too, and i have internet. Thank you all again and especially you Gregg. –  Nick Feb 19 '12 at 20:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.