Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a few (Linode) Ubuntu 10.04 (64bit) VPSes, and mysqld keeps starting on every reboot on all of them --

$ uptime
 16:32:26 up 1 min,  1 user,  load average: 0.09, 0.08, 0.07

$ ps -ef | grep -i mysqld | grep -v grep
mysql     2364     1  0 16:17 ?        00:00:00 /usr/sbin/mysqld

$ sudo sysv-rc-conf --list mysql
mysql        2:off      3:off   4:off   5:off

$ sudo chkconfig -l mysql
mysql        0:off  1:off  2:off  3:off  4:off  5:off  6:off

$ sudo /etc/init.d/mysql stop

$ !ps
ps -ef | grep -i mysqld | grep -v grep

How else can I turn it off?

P.S. I raised this question to Linode but they are unable to answer.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

If you don't need mysql, why not remove it altogether?

sudo apt-get remove mysql-server

should do the trick

share|improve this answer
add comment

Add an upstart script that turns it off after it starts...or edit the upstart script for mysql to do nothing.

share|improve this answer
add comment

MySQL daemon is started automatically by UpStart service.

The configuration file is located at /etc/init/mysql.conf .

If you want to disable it at next reboot :

sudo sh -c 'echo manual >> /etc/init/mysql.override'

If you want start manually the MySQL daemon :

sudo service start mysql

If you want to restore automatic start of the daemon at next reboot :

sudo rm /etc/init/mysql.override
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.