Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed 3.2.4 from Oneric mainline and boots and runs everything perfectly. However cannot remove 2.6.38-13 without it claiming a broken package.

Have used synaptic to fix broken but still cannot remove.

share|improve this question
1  
did you build any custom packages or kernel modules that depend there? –  hbdgaf Feb 14 '12 at 1:35
    
Well, Natty was installed with whatever kernel comes with it. The machine has seen dist-update many times. The last kernel installed before 3.2.4 was 2.6.38-13 generic pae. I have not built any packages but I have installed many applications. –  Ringtail Feb 14 '12 at 2:03
    
My guess is that one of the applications built a kernel module...virtualbox for example –  hbdgaf Feb 14 '12 at 3:10
    
If that were the case when I installed the new kernel wouldn't it be overwritten? –  Ringtail Feb 14 '12 at 3:35
    
No. A new kernel doesn't pull in modules built by packages. Just because the module still works just means there wasn't an API change that caused it to crash yet. Some might not complain by depending on linux-headers instead of a version. It's something you take responsibility for when you start using things that require kernel modules. –  hbdgaf Feb 14 '12 at 3:59
add comment

1 Answer

up vote 2 down vote accepted

Try this one-liner and see if it fixes it for you:

apt-cache rdepends packagename  
share|improve this answer
    
$ apt-cache rdepends linux linux Reverse Depends: |zramswap-enabler I can see this may be the issue –  Ringtail Feb 14 '12 at 6:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.