Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Neither of these answered my question:

How do I disable the F10 (application menu) keybinding in Ubuntu 11.10?

How do I deactivate F1 and F10 keybindings?

The instructions in that thread seem to be specific to Gnome or compizconfig-settings-manager. That application looks a bit dangerous so I'm wondering if there's a way to do this without it. There's a keyboard shortcuts dialog but I couldn't find F10 in there.

This shortcut is colliding with a shortcut in Chrome that is used for debugging. It's pretty annoying that Ubuntu would assume no applications would be using the F10 key. I use at least 3 applications that need that key frequently.

11.10 screenshot

I'm using ubuntu 11.10

share|improve this question

1 Answer 1

up vote 6 down vote accepted

CCSM is mostly a GUI front-end which writes its values to the gconf database.

You can use gconf-editor to edit the compiz unity plugin options:

enter image description here

As you can see in the image - the F10 key is associated with the panel option located in the gconf path /apps/compiz-1/plugins/unityshell/screen0/options/panel_first_menu

Thus you can change this to another key value - or write the value Disabled to disable the F10 key altogether.

If you want to reassign the key, you can use the modifiers in combination to perform multikey shortcuts:

  • <super> for the WIN key
  • <alt> for the ALT key
  • <shift> for the SHIFT key

For some options you need to logout and login for the changes to take effect.

If you want to reassign/disable from the command line you can use the syntax:

gconftool-2 --set '/apps/compiz-1/plugins/unityshell/screen0/options/panel_first_menu' --type string 'Disabled'
share|improve this answer
    
Doing that does solve the F10 key problem in 12.04. –  Paweł Gościcki Apr 30 '12 at 18:21
    
in 12.04 this key-value by default is no longer F10 - it is now Alt+F10 so there shouldnt be an issue with F10 itself. –  fossfreedom Apr 30 '12 at 18:42
1  
i installed 12.04 and i cannot get rid of this F10 feature. in gconf-editor it is disabled, the same thing in CompizSetting. On Terminal i disbaled the F10 function as well, but still, a context menu is popping up pressing F10. whats wrong? –  NovumCoder May 2 '12 at 14:02
    
This is a general Q for all apps - there is a bug in 12.04 specifically for the terminal. There is a good answer that should resolve this: askubuntu.com/a/128800/14356 –  fossfreedom May 2 '12 at 14:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.