Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just a quick question: I have noticed when I boot into Ubuntu my battery goes empty faster, and checking the "time left" option in Leopard and Ubuntu it says Mac will last 3 hours where Ubuntu will last 1.

Is that normal?????

share|improve this question
    
Yeah, it is. Common problem. –  RobinJ Feb 13 '12 at 18:05
    
It seems changing the NVIDIA propietary driver to "current-updates" helped in my case. –  aderojas Feb 14 '12 at 18:46
add comment

3 Answers

up vote 9 down vote accepted

I would say battery life issues are not uncommon with specialized hardware. Particularly with Apple laptops, you will find many such issues in the Ubuntu forums. But the good news is usually you can tweak and adjust your laptop performance until it gets to pretty normal.

For example, with my Macbook Air, currently I get about 5 hours in OS X. With similar usage, I found I got about one hour of battery life on 11.10.

But it turns out 11.10 has some power management issues due to the 3.0 kernel. Supposedly 12.04 would fix that and I had a couple other issues anyway, so I upgraded to the alpha version. After that, I got about 2 - 2.5 hours. Then I learned about laptop-mode-tools (given how useful people find this, it's amazing this is not part of the default install for laptops...). Now I find I get about 4 hours. So I'm satisfied.

I've made a comparison of watts used and clearly Ubuntu is just using more than OS X. At idle, OS X is using 9-10 watts, while 12.04 is using 12-13. Part of it is due to this mysterious "display backlight" issue I'm running into, which takes about 2-2.5 watts.

Update: Here's more info about laptop-mode-tools. This is the website for it. From its FAQ, if you want to check if it's running, type cat /proc/sys/vm/laptop_mode at the command line; nonzero value means its running. Also, the configuration file is at /etc/laptop-mode/laptop-mode.conf. To read the manual for it, type man laptop-mode.conf at the command line. To alter the config file you will need to do it as root, e.g. gksu gedit /etc/laptop-mode/laptop-mode.conf. Be careful doing that! If you want to disable it, to test your system, near the beginning of the file, you should see the option ENABLE_LAPTOP_MODE_TOOLS with the value of 1 -- change it to 0 and shutdown/restart.

share|improve this answer
    
I'll look into 'laptop-mode-tools'. Any idea what am I looking for there? –  aderojas Feb 14 '12 at 18:47
2  
The beauty of laptop-mode-tools is that it configures a lot of stuff automatically for you. I haven't had to make any adjustments to its configuration file. But if you google, you can find the developer webpage and other useful sites that will explain how to tweak your configuration. I'd also recommend powertop -- it is a diagnostic tool that will show you what is consuming the most energy and it also makes recommendations of what to adjust (but unfortunately it doesn't let you save those recommendations). –  Chan-Ho Suh Feb 14 '12 at 19:15
    
I installed the laptop-mode-tools via de synaptic package manager. Now what? I don't see any new application installed or how to set up stuff.... how do I know if it's already working? –  aderojas Feb 14 '12 at 22:11
    
Apparently there is a bug and that's why it doesn't work. I get the exact same thing when trying sudo /usr/sbin/laptop_mode: bugs.launchpad.net/ubuntu/+source/laptop-mode-tools/+bug/824643 –  aderojas Feb 14 '12 at 22:29
    
This seems to solve it: stevenprc2-blog.blogspot.com/2011/11/… Now... do I have to run it everytime I boot into Linux? Do I have to edit /usr/sbin/laptop_mode? Is there anyway to turn off the option that "disconnects" the mouse if I don't move it for a few seconds until I click again? –  aderojas Feb 14 '12 at 22:37
show 8 more comments

The real issue here is the graphic card, this part use a lot of power. Natively, the Leopard OS will manage and switch automatically between the more and the less powerful graphic card.

On Ubuntu, you will need to use a patch to be able to select which graphic card you want to use according to what you are doing.

I hope it will help you and you will see some improvements.

share|improve this answer
    
And how do you apply all that? Will it work on my MacBook Pro 5.1 as well? –  aderojas Feb 15 '12 at 14:12
add comment

3 times is a bit extreme. I suspect at least part of the difference may be due to the difference in algorithms estimating battery usage. Try running your laptop until the battery is dry with MacOS and Ubuntu - you may find that Ubuntu lasted 1.5 hours and MacOS lasted 2 - that would be more likely.

I mean - I'm getting 1 hour of battery life with Ubuntu from a cheap 6-year old Compaq laptop... Apple must be making very bad hardware for it to last 1 hour :)

share|improve this answer
    
Thanks. I understand that different OS calculate it in different ways, but I definitelly notice Ubuntu needing more resources. It also heats up the computer more and the vent has to go crazy once in a while. I'll run your test using the computer for the same stuff to see what happens. Thanks. –  aderojas Feb 13 '12 at 21:42
    
Battery usage depends strongly on the OS and OS configuration. Additionally, the estimates may not be reliable. But, we cannot reasonably expect battery times to be the same between different OSs. –  Jan Feb 13 '12 at 22:07
    
Thanks Jan, I understand that. But I'm still surprised that Ubuntu uses so much more resources and heats up the computer so much. I'm looking for solutions to manage that better, since I'm afraid this overusage might damage the hardware. –  aderojas Feb 14 '12 at 0:38
    
If your laptop is constantly hammering at 100%, overheats, coolers work at 100% all the time, screen does not dim etc. - this is not a normal operation for Ubuntu. I would expect Ubuntu to have slightly bigger (or similar) power consumption compared to MacOS - when working normally. So, to directly answer your question: NO, this is not normal. –  Sergey Feb 14 '12 at 0:57
    
System Monitor shows CPU1 and CPU2, and it seems that one of them is always at 100%. I have been reading in the Ubuntu forum and apparently this is a known issue, and I should do some stuff to manage the NVIDIA card so it uses less resources. Any ideas?? –  aderojas Feb 14 '12 at 1:26
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.