Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently upgraded my onboard Nvidea graphics chip with an ATI Radeon Sapphire X800XL PCIe graphics card. Ever since I am unable to run Stellarium. I get the error "This system does not support OpenGL". The only thing that has changed since I last run Stellarium (other than the weekly updates) is the new card. I have tried other fixes like this one to no avail. I have also tried to re-install the ATI plugin and Catalyst drivers in Software Center with no change. I remember once finding the list of Nvidea drivers available and being able to switch between them, where is that box again?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Found the answer on Ubuntuforums.org

It looks like my new ATI drivers were conflicting with the old Nvidea ones that required the boot first, like this:

sudo apt-get remove --purge nvidia*
sudo sh /usr/share/ati/fglrx-uninstall.sh #don't worry if this command fails
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

After completing the Nvidea purge and ATI re-install all works well :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.