Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm experiencing freezing and glitches while watching streams online, especially HDs. Ex. http://www.en.aljazeerasport.tv/ which is flawless on Windows and glitchy / freezing on Ubuntu

Current setup ~

share|improve this question
    
Please edit your question to focus on one issue. And post other, specific questions for each of your other issues. –  user25656 Feb 13 '12 at 14:42
    
There may be a hardware problem at play here (same would happen on Windows if you were, say, using the wrong drivers). Some hardware information would be appreciated; computer make, model, and if possible output of running lspci on a terminal. Thanks! –  roadmr Feb 13 '12 at 14:44
    
Thanks for your answers. Here's my most used setup ~ pastebin.com/NFgRwYTK Any clue? –  Adame Doe Feb 13 '12 at 15:45
    
What browser are you using? Are you using the 64-bit or 32-bit version of flash? –  tgm4883 Feb 13 '12 at 16:54
    
Chromium 16.0.912.77 with Flash 64 - 11.2.202.197. I also tried Firefox with same flash version but it's the same result : glitches and freezing, and drastic video quality drop... which make the stream not enjoyable at all. –  Adame Doe Feb 13 '12 at 17:13
add comment

1 Answer

Sounds like dropped packets and high ping times. If you say Windows works fine then the problem should be from your Ubuntu system to the router.

First find out the IP address of your default gateway. One way to do it is by running this in a terminal:

ip route list |grep default

you'll get something like this:

default via 192.168.108.1 dev wlan0  proto static

next, on the terminal, try pinging the gateway, to get an idea of packet loss and roundtrip times:

ping -i .200 -c 100  <gateway ip address>

You'll get a running count of pings, and a report at the end:

PING x.x.x.x (X) 56(84) bytes of data.
64 bytes from x.x.x.x: icmp_req=1 ttl=64 time=8.55 ms
64 bytes from x.x.x.x: icmp_req=2 ttl=64 time=4.82 ms
64 bytes from x.x.x.x: icmp_req=3 ttl=64 time=3.67 ms
64 bytes from x.x.x.x: icmp_req=4 ttl=64 time=2.87 ms
64 bytes from x.x.x.x: icmp_req=5 ttl=64 time=3.16 ms
64 bytes from x.x.x.x: icmp_req=6 ttl=64 time=17.5 ms
.
..
64 bytes from x.x.x.x: icmp_req=100 ttl=64 time=0.971 ms

--- 10.153.108.1 ping statistics ---
100 packets transmitted, 100 received, 0% packet loss, time 19856ms
rtt min/avg/max/mdev = 0.888/2.408/16.572/2.469 ms

You'd want to see no packet loss and an avg rtt time of maybe 100 ms for things to run smoothly. If you lose packets or you notice that the running count shows some wild variations in rtt times, that may be what's causing the glitchiness. A mismatched or wrong driver may be the cause.

Are you connected through your wired or wireless interface? Also, your HW info suggests it's a laptop. If that's the case, could you check if you get the same results when it's plugged into AC power? some wireless adapters go into "low power" mode which may adversely affect performance.

share|improve this answer
    
100 packets transmitted, 100 received, 0% packet loss, time 19874ms rtt min/avg/max/mdev = 1.733/2.743/12.692/1.324 ms –  Adame Doe Feb 13 '12 at 17:47
    
I'm using a laptop, wireless but permanently connected to AC, cause it's like my media player laptop which I connect all the time to TV so I can watch streams. –  Adame Doe Feb 13 '12 at 17:48
    
These numbers look fine, so it's apparently not that :/ and FWIW Al Jazeera Sport works just fine for me (Ubuntu 11.10 64-bit) so it's something more specific to your situation. I'm thinking video performance is the next area to focus on. Do standard-definition streams work well? what about HD Youtube videos? are you using the proprietary nvidia drivers? how does the system handle local HD video? –  roadmr Feb 13 '12 at 20:19
    
Youtube HD works just fine, but I believe it's not the same protocol. Youtube can even be played without flashplayer (HTML 5 video playback). What I'm having trouble with is live streaming media using RTMP protocol for most. –  Adame Doe Feb 13 '12 at 22:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.