Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I run aptitude safe-upgrade, I get this output:

The following partially installed packages will be configured:
  cups gconf2 ufw update-manager 
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

How can I configure the four mentioned packages?

I tried dpkg-reconfigure gconf2 but that fails with

/usr/sbin/dpkg-reconfigure: gconf2 is broken or not fully installed
share|improve this question
up vote 16 down vote accepted

Run these codes

sudo apt-get update

sudo apt-get clean

sudo apt-get autoremove

sudo apt-get update && sudo apt-get upgrade

sudo dpkg --configure -a

sudo apt-get install -f

This will clean and configure your packages

share|improve this answer
Might be useful to some. During autoremove I got one additional error: E: Could not perform immediate configuration on SOMEPACKAGE. That was resolved by apt-get install -o APT::Immediate-Configure=false -f apt SOMEPACKAGE – dnsmkl Mar 3 '15 at 19:50

This command fixed my problem:

apt-get --purge remove program_name

But of course you need to try also @ringtail answer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.