Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Ubuntu 11.10, I am having a problem browsing web pages. I tested my connection by pinging different sites. All of them reply to me, but my browsers do not work. The problem is not specific to one browser, as I have tested both Firefox and Chromium.

This is the wget output when run in Terminal:

wget ubuntu.com
Resolving ubuntu.com... 91.189.94.156 Connecting to ubuntu.com|91.189.94.156|:80

No error is raised. What do I have to do?

Thanks for every bodies answers.

My problem was from IPV6 activat.

Open the firefox browser and type:

about:config

Press accept button with the text I'll be careful, I promiss!

then enter IPV6 in filter field. just one entry remain in list with text network.dns.disableIPv6. Right click on this and press Toggle. the value field must be true.

After, take logout and logon again.

Now test again!

I did the above stream.It got solve for some minutes but the problem started again.

So now I have not the page loading in my ubuntu.

share|improve this question
1  
Which type of connection is your using? –  Tachyons Feb 13 '12 at 8:55
    
And whats your connection speed (use system monitor) try to install apps from ubutu software centre is it possible? –  Tachyons Feb 13 '12 at 8:57
    
I am using wireless connection and nothing done here. Update, upgrade, browsing page and etc. –  Amin Feb 13 '12 at 9:00
1  
Could you start wget http://www.ubuntu.com/ from a terminal and confirm that you get an index.html in the current working directory? If not, please post the appearing messages, we might catch a hint of the problem. –  lgarzo Feb 13 '12 at 10:26
1  
@Amin One thing popped into my mind as I was walking into work: you could try to boot from a Live CD and test from there. I assume the Live environment worked for you when you first installed Ubuntu. Since it is considered an untouched system it crosses out any problem regarding your installation and leaves only the wireless router (or your adapter / or any transmission problem). –  lgarzo Feb 14 '12 at 8:50

3 Answers 3

The problem was related to IPv6.

  1. In Firefox's URL bar type: about:config

  2. Click the button with the text I'll be careful, I promise!

  3. Enter IPv6 in the filter field. Just one entry named network.dns.disableIPv6 should remain in the list.

  4. Right click on this and press Toggle. The value must be true.

After that, logout and login again, and it should work.

share|improve this answer
  1. Are you sure that is a browser problem? Do you have a proxy? Check your browser Firefox -> Modify -> Precerences -> Advanced -> Connection
  2. Do you have a trasparent proxy? Check with this: http://www.lagado.com/proxy-test
  3. Does your ISP block http traffic? You say that ICMP works, check ftp, ssh and other protocols
share|improve this answer
    
I was using my internet tile 3 days ago.this problem raised newly. I have no proxy and can ping every site I want. –  Amin Feb 13 '12 at 9:57
    
I connected now with the windows.So there is no ISP problem. and I checked the firefox for proxy.No proxy is set. I have chromum too and I have this problem yet. –  Amin Feb 13 '12 at 10:07
    
Can you change your IP? Reboot wireless router or access point? What is between you and internet? I think that is a filter router-side –  Alessio Feb 13 '12 at 16:29
    
Me-wireless modem-ISP –  Amin Feb 13 '12 at 17:51

Your browser is set to work offline.

For example in Firefox under File > Work offline. Untick "Work offline" to resolve this.

share|improve this answer
    
:O .the problem is not just for browser. wget, update and etc have this problem so. –  Amin Feb 13 '12 at 14:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.