Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install any form of Linux, including Ubuntu, Kubuntu,and even Mint the installation gives me an error because if my PCI device which is my GPU. This error flashes over and over again, and then times out. I want to dual boot windows 7 and Ubuntu but Ubuntu simply fails to install.. whats wrong? I know the problem is because of my GPU because it will install with on-board graphics..

share|improve this question
2  
And what error does it give you?... FYI, when you say any form of Linux and then you Say Ubuntu, Kubuntu and Mint, your're basically using the same OS. –  Uri Herrera Feb 13 '12 at 3:31
add comment

4 Answers 4

I have similar problems installing Mint 12, Oneric, Precise Beta and some others. I think the free Nouveaux Drivers don't support this board yet, so can't launch an x-server. I have posted a bug in the hope someone will pick it up and fix it.

https://bugs.launchpad.net/ubuntu/+bug/969121

I have been told that you can use Ubuntu Customisation Kit to respin Ubuntu to load the non-free proprietary drivers when your live system boots. However, I don't know that it would be an easy fix because it takes more space on the disk, which would mean you would have to do a USB mounted burn of the .iso, not to mention you would have to tell the installed version to load those drivers also. If I find a way to triage this, I'll let you know.

share|improve this answer
add comment

I am using a GeForce GTX 560 Ti in an ubuntu 10.10 and the NVIDA development drivers with no problems. Download the drivers from here, and here you have a tutorial of how to install them. It is quite easy and smooth.

They claim to have full support for 550 ti cards in driver version 295.59, so that should work for you.

share|improve this answer
add comment

Last week I spent 3 days trying to get a GeForce GTX 550 ti working in various flavors and versions of Ubuntu.

In the LTS version of Ubuntu - 10.04 - it is necessary to download and install the drivers (currently version 295.33) from the NVIDIA web site. Without them Ubuntu runs in a basic VGA-type mode.

In Xubuntu 11.10 it will work and use the Ubuntu-provided driver at version 280.13 from the Ubuntu Software Center.

This seems to work well

share|improve this answer
add comment

I've had Gigabyte GTX 550 Ti some time ago and the same problem appeard. Basically to install Ubuntu with this card you must set up nomodeset in installation boot screen. To do this just press F6 when installation options(Try, Install etc.)shows and check nomodeset option - installation will go smoothly after this. When the installation of OS is finished just install gpu driver from Additional Drivers menu and... that's it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.