Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In /etc/postfix/main.cf I have [relayhost = smtp.someisp.no] and everything works fine. I have to use this relayhost since my ISP has closed port 25. My ISP tells me that if I dont want to use their relayhost I have to configure my mailserver to use a ssl port like port 465. Then I can remove the relayhost option. Do anyone know where I do this like which files to edit and is this possible if I dont set up my server as a DNS Server?

share|improve this question

1 Answer 1

It sounds like you're talking about two different things.

If you need to configure a relayhost, it is because outgoing access to port 25 has been blocked by your ISP. Given that the mail servers listen on port 25 by convention, you will almost certainly have to use a relay host of some variety.

My guess as to what the person at the help desk was suggesting was that if you wanted to contact a particular mail server outside the ISP's firewalls, then that mail server should be configured to listen on a second port. Some reasons you might want to do this is if your company required that all mail be sent via their servers, or you'd set up restrictive SPF rules such that mail sent via your ISP would be rejected. One thing to keep in mind here though, is that this would just be trading one relay host for another.

If you don't have such an external mail server in mind, then the suggestion about changing the port doesn't really apply. In that case, relaying via your ISP's mail server is probably the best option.

share|improve this answer
    
Thank you for your help, sir. Since I have registered my own domain mypublicdomain.no which point to my static ip-address I thought I could use mail.mypublicdomain.no as relayhost. I know I can use that in /etc/postfix/main.cf but where do I put the port 465 option? Which files should I edit to make this happen? –  Bob Feb 13 '12 at 14:36
    
Is mail.mypublicdomain.no pointing at the same machine you're running Postfix? If it is, then you'd be configuring your mail server to deliver mail to itself in a loop, since the relay host is the server all mail is sent to that can't be handled locally. If it is a separate host outside of your ISP I'll update the question, but it isn't clear that would help you. –  James Henstridge Feb 14 '12 at 0:50
    
This is how everything is set up. I have an ISP that provides my Public Static IP. They block port 25. I have registered mypublicdomain.no through ANOTHER company (WEB Server Company) that has nothing to do with my ISP company. On the WEB Server Company I have this configuration: MX-Entry: Priority=0 Destination=mail.mypublicdomain.no Note: Email routing is configured as a remote mail exchanger in cPanel. That configures the server to NOT accept mail locally and sends mail to the lowest MX record. –  Bob Feb 14 '12 at 8:08
    
DNS Zone File Records:<br\> Name TTL Class Type Record<br\> mypublicdomain.no. 7700 IN A 1.1.1.1<br\> localhost.mypublicdomain.no. 7700 IN A 127.0.0.1<br\> mail.mypublicdomain.no. 7700 IN A 1.1.1.1<br\> www.mypublicdomain.no. 7700 IN CNAME mypublicdomain.no<br\> ftp.mypublicdomain.no. 7700 IN CNAME mypublicdomain.no<br\><br\> Note: The RECORD IP Address above is modified here by me and substituted with a fictive IP Address. The RECORD IP Address above points directly to my Public Static IP.<br\> All the information above is set up in cPanel located at my WEB Server Company. –  Bob Feb 14 '12 at 8:10
    
I am sorry I cannot display this in a better way. Here they say if I use 2 spaces at the end of a line I get line shift but that is not the case. I hope you can read this anyway. –  Bob Feb 14 '12 at 8:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.