Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install a very minimal Gnome environment on an Ubuntu server running on minimal server hardware (i.e. no graphics card) behind a KVM switch. Yes, I know that's generally frowned upon. I read the wiki's Server GUI notes, but it only mentions how to install the entire desktop environment, not just the core.

So I ran sudo apt-get install gnome-core xinit xorg then rebooted. Afterwards, it came back up to a terminal login, which is fine. I logged in and then tried running startx, but received the error:

(EE) Failed to load module "ast" (module does not exist)
(EE) open /dev/fb0: No such file or directory
(EE) VESA(0): V_BIOS address 0x5f6e0 out of range
(EE) Screen(s) found, but none have a usable configuration.

Fatal error:
no screens found

I read here and here that I should try deleting my /etc/X11/xorg.conf and rebooting, but the file /etc/X11/xorg.conf does not exist on my system.

What else do I need to do to resolve this error and get Gnome running?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Have you tried generating an xorg.conf file since you don't have one? Check this link for the command and documentation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.