Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude E5400 with Ubuntu 11.10, and I have noticed a problem when waking up from sleep. I would close my lid, the laptop would go to sleep, but when I open the lid and it wakes up it shows my locked screen for a couple of seconds and then logs me out and takes me back to the login screen.

I had this problem earlier, but I figured out that it was because I unplugged my USB mouse while it was on sleep. Now I have this problem even when the hardware does not change.

share|improve this question

closed as off topic by jrg May 21 '12 at 20:35

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Sounds like your X server is just crashing on resume, this probably should be reported as a bug report. –  Jorge Castro Feb 13 '12 at 0:58

1 Answer 1

I've seen this, and assumed it was simply showing the video buffer briefly before refreshing the screen. I assume that if you were to disable the option to lock the screen after some time (in the Screen settings dialog), that it would not do this.

If it does, then there's definitely a problem. But I think it's probably normal, perhaps even a "feature" so you can catch a glimpse of what's there, but nobody can use it. You could probably lock the screen manually before leaving to avoid the problem if it bothers you, but in my case, there's really not enough time for anyone to see much.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.