Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here's my story, short as possible:

It all started two years ago when two laptops with Windows became unusable. I had nothing to lose, and went for a clean install of Ubuntu. We were thrilled with the results, and have been until Monday.

Monday, I decided to buy a desktop off Craigslist (the laptops are now old), and just pop Ubuntu 10.04 on it from the same install CD.

Everything went fine, and the computer was running smooth, until i discovered I couldn't plug in my ethernet cable for internet.

I played with the Network tool (in the status bar), and also Network Tool.

I put in my IP manually, and eventually it said it was connected, and showed activity, but I still had no internet.

Being busy with work, I never intended to use the ethernet anyway, and bought a USB adaptor for $10 off Amazon which was recommended as "trouble free." (Raylink RT5372 USB)

It doesn't work. I tried downloading the driver, and compiling the .bz2 file into a .tar and installing from the terminal. Didn't get any errors, but it isn't working.

As potential solutions, I downloaded, and installed:

  • Fedora
  • Mint
  • Ubuntu 11.10

My Raylink wireless card worked fine with any and all of those distros, but it seems that my ATI Radeon 9200 graphics card isn't very compatible, and the computer slows to a crawl.

I've been poking around the internet all week looking for, and trying, possible solutions.

Any advice?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

All of the other distros you have tried have newer kernels that 10.04.

It is very likely that your problems can be traced back to this.

Fortunately, 10.04 has the Oneiric (11.10) kernel backported and available to be installed.

Since you have no internet connectivity, you will need to either:

  1. Remove your hard-drive and and plug this into a computer that has a different NIC which you can connect to the internet with. Use the linked question above to install the PPA and the latest kernel
  2. Download the backported packages manually, transfer to your computer and install.

If you choose choice 2 - download the image package appropriate to your architecture

i.e. 32bit and 64bit

then install using the syntax:

sudo dpkg -i [foo].deb where [foo] is the package filename

You can check that you have boot correctly with this newer kernel via uname -a

enter image description here

share|improve this answer
    
That makes sense. I appreciate the feedback. This is probably easier than trying to install the drivers for the Raylink USB wireless card. Right now I'm back on 11.10, and wanted to try following the suggestion of booting into 2d, but it's still very slow and unresponsive; especially when moving windows. –  Atlas Friedman Feb 12 '12 at 23:51
    
It appears that the simplest solution to all this may be upgrading the graphics card. –  Atlas Friedman Feb 12 '12 at 23:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.