Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Tecra A4 laptop. How can I ensure I have the latest graphics driver for it?

According to http://alatest.com/reviews/laptop-reviews/toshiba-tecra-a4-s211/po3-32484355,30/#details, I have a ATI Mobility Radeon X600/NVIDIA GeForce Go 6600

When I go to System > Administration > Additional Drivers, it does a check and says "No Proprietary Drivers are in use on this system" with a black list box and a disabled Enable button.

share|improve this question
2  
Might be useful to give a little more information, such as the graphics chipset in the laptop (ATI/AMD, NVIDIA, or Intel). –  Jacob Peddicord Oct 30 '10 at 2:43

2 Answers 2

up vote 1 down vote accepted

If you have ATI Mobility Radeon X600, then you cannot use proprietary drivers, as AMD discontinued support of this card.

If you have NVIDIA GeForce Go 6600, then you can install drivers via System > Administration > Additional Drivers.

Post output of lspci command for sure.

share|improve this answer
    
lspci verifies I have an ATI card. Thanks. –  Davious Nov 1 '10 at 23:05

In general, if you keep your system up-to-date via Update Manager (under System > Administration > Update Manager) then the latest tested graphics drivers will automatically be installed.

If you have an NVIDIA or ATI/AMD graphics card, then you can opt-in to the manufacturer-supplied drivers by going to System > Administration > Additional Drivers.

Updated from your question:

When I go to System > Administration > Additional Drivers, it does a check and says "No Proprietary Drivers are in use on this system" with a black list box and a disabled Enable button.

If this is the case, your laptop may have an integrated Intel GMA chipset, which does not require proprietary drivers (and you're already up-to-date). I googled around and found that many Tecra A4 models in fact have Intel GMA chipsets instead of NVIDIA or ATI.

share|improve this answer
    
Thanks for your help. –  Davious Nov 1 '10 at 23:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.