Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to connect my laptop to an external display. But the attached display isn't shown in ubuntu and neither is the laptop screen. I have an Nvida 9600 gm card and I would like to connect another screen via VGA port. How can this be resolved?

share|improve this question
    
Are you using the NVIDIA driver? –  Tom Brossman Feb 12 '12 at 16:10

1 Answer 1

according to google, your laptop uses the Geforce 8400GS graphics card. Here's a link for the driver download: 64-bit http://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/XFree86/Linux-x86_64/295.40/NVIDIA-Linux-x86_64-295.40.run&lang=us&type=GeForce
32-bit: http://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/XFree86/Linux-x86/295.40/NVIDIA-Linux-x86-295.40.run&lang=us&type=GeForce

The installation is a bit tricky and unintuitive.

After you have logged in to your system please press ctrl+alt+f1 You will be dropped into a command line shell where you'll have to log in again (if you type in your password the screen will show no response it's supposed to be like that for security reasons).

After you have logged in please type

sudo killall lightdm
sudo stop lightdm

This is just to make sure that no instance of your display manager is running anymore. (which is causing the installation problem in graphical mode)

now change directory to your download folder (or whereever you have stored the nvidia driver setup)

cd /home/'your_username'/Downloads

(you'll obviously have to put in your real username and without the apostrophies)

To make the driver executable type

sudo chmod +x NVIDIA-Linux-x86-295.40.run

and finally to run the installer

sudo sh NVIDIA-Linux-x86-295.40.run

You will be guided through the installation process. Please make sure you build an initial xconfig file (it's the last option in the installation dialog).

Now when everything is done, type

sudo reboot

to restart your computer. Your driver should now be installed correctly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.